Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence: Merge function in tables does not work

I'm trying to create a table and I need to merge cells from 3 rows on top of eachother but apparently the built-in editor in confluence won't let me..

What should I do ?

Thank you for your answer..

Regards

Peter

5 answers

My solution (using Firefox): Before merging, ensure ONLY the inside of the cells is highlighted as opposed to having both the inside AND the borders highlighted.

Assume you want to merge all cells in a row.
1. Click inside the leftmost cell and drag to the rightmost (don't release the mouse button yet).

    The cells and the cells' borders highlight in blue.

2. Continue dragging to the right until the mouse pointer is outside of the table borders (don't release the mouse button yet).
3. Drag back to the rightmost cell.
4. Release the mouse button.

Voila! The cells are highlighted without the borders being so! Now you can merge.

This works for me on firefox.

This was the secret sauce. It works now!

1 vote
Shannon Atlassian Team Feb 14, 2018

Hi Peter,

I'm testing this out in 6.7.0 and compared to 6.4.0, the merge doesn't seem to work. I've reported this as a bug:

I've included some animated GIFs in that bug. Can you have a look at them and let me know if that's what you're trying to do?

If not, can you describe what isn't working for you and I can test that out as well?

Either way, please let me know your Confluence version so I can include this.

Regards,
Shannon

Hey Shannon

Thank you for reporting it and it is exactly the same thing I was trying to do.

I had to resort to excel and exporting that to pdf and inserting that pdf..

Not the most elegant solution but at least it works better..

I have no idea where to find the current version number of confluence but as we bought it for like a week ago it's probably the latest version..

Kind regards

Peter

Shannon Atlassian Team Feb 14, 2018

Peter,

No worries! Is the blue a bright blue (like at the top of this page), or more of a navy blue? If it's bright blue then you're probably testing with either 6.7.0 or 6.7.1, which matches what I reported in the bug. You can check the bottom of the pages, though, it should say the version.

Screen Shot 2018-02-14 at 5.18.27 PM.png

If it's not 6.7.0 then I can update the bug with your version as well.

Shannon

it's 6.7.1 cause it's blue.. Cannot see version number though.
Might have something to do with me using linux..

Anyway, thank you for reporting..

regard

Peter

Shannon Atlassian Team Feb 15, 2018

No problem, Peter! Thank you for confirming that.

Just keep an eye on that bug for any status updates.

Regards,

Shannon

Shannon Atlassian Team Mar 01, 2018

@Arbit Support @Peter Nielsen

On the bug ticket, CONFSERVER-54986, the developers have a few questions for you about replicating the issue. 

Can you have a look there and respond on it? It will help them to determine the root cause.

Thank you!

Regards,

Shannon

To merge I used to just drag the mouse across the cells I wanted then do the merge. Now I must triple click the content in one cell then shift-arrow <direction> to the cell(s) I want to merge.

So depending on how you select the cells to merge, it's not only broken in 6.7 but 6.14.2 as well.

Like # people like this

Dear all,

 

I quick fix I have found with Firefox is to actually click and hold on the first cell , move your cursor to the right cell so that it select both cells, move your cursor to the left so that it only select the first cell, move it to the right so that it select both cells again and then lift your finger. What it does is that it creates another type of selection that can now be merged.

 

Cheers.

This is a IE problem, use Chrome will resolve it.

In 6.15.3, I've just discovered a bug with merging table cells in IE. Previously I could enter the details in one cell, then select the cells I would like to merge with, click merge, then that data would span across the cells. I tried the triple-click +shift-arrow and it didn't work for me. I tried deleting the details in the cell, and it worked. It seems I can only merge blank cells. I've reported this through Support.

Well, I can just confirm that this no longer works, and I can't merge cells! gremlins

Like Bruno Mota Penteado likes this

Hi, have you reported this?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence Cloud

🎨 Add some visual life to your templates

Hi Atlassian Community, My name is Avni Barman, and I am a Product Manager on the Confluence Cloud team. Based on feedback from you, we are giving admins more power to create templates that a...

293 views 5 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you