Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence Jira Macro - You do not have permission to create issues on this Jira server. Edited

I have exhausted all my checks and read all relevant community and support tickets.

The Confluence Jira Macro does not work properly in my setup. I can open the dialog but can neither search nor create Jira Issues from Confluence (see error msg in post title).

Application Link is set up correctly both ways with OAuth enabled and working properly. I am successfully using Jira user directory to authenticate in Confluence (Jira is primary user directory). Collaborative editing works fine.

Confluences Spaces are connected to Jira Projects in Space configuration. Users have correct roles in Jira and Confluence.

All Jira related system plugins are enabled in Confluence. 

Both Jira Core and Confluence are installed on the same Windows VM. Connection is routed over SSL thru an IIS Proxy. Certificates are valid. No other issues on either Application. 

Base URLs are: https://jira.<mydomain>.com and https://wiki.<mydomain>.com

Browser Console (Chrome) shows http 400 error (bad request) on URL: 

https://wiki.<mydomain>.com/plugins/servlet/applinks/proxy?_=...

https://wiki.<mydomain>.com/s/.../_/download/contextbatch/js/editor-v4,atl.general,editor,macro-browser,page,main,-_super/batch.js?frontend.editor.v4=true&healthcheck-resources=true&hostenabled=true&locale=en-GB&whisper-enabled=true

When I try this URL in a separate browser window, I get java.lang.NullPointerException
   at com.atlassian.confluence.plugins.jira.AppLinksProxyRequestServlet.doProxy(AppLinksProxyRequestServlet.java:60)

A problem with the IIS reverse Proxy? I checked SSL Configuration in IIS and noticed, that the Jira Application was not configured to accept client certificates. So I switched that option on. This resulted in the Jira Macro to show the Create Issue dialogue - but only once. The fields where read-only. Since then, same behaviour as before. 

I checked the http request parameter length in the Windows registry which was described in another thread as a possible issue. It is 4096 in length and therefore probably no issue here.

Confluence is v6.15.4 and Jira Core is v8.3.2

Any ideas are much appreciated. Thanks.

 

5 answers

1 accepted

0 votes
Answer accepted

I meanwhile solved the problem by configuring the application links with oAuth with impersonation both ways. Now it works!

I have seen this error once and it was a while ago so I cannot remember all the items that had to be fixed because it was a different worklife; I confluence reindexed? It was a while ago and if I remember correctly it was a combo of issues; check the browsers and the firewall and time out issues by the browers and JIRA.

Update: 

I checked the IIS http Log and it says: 

GET /sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml jqlQuery=project%20%3D%20XYZ&returnMax=true&tempMax=20&field=summary&field=type&field=link&_= <some key> &X-ARR-CACHE-HIT=0&X-ARR-LOG-ID=<session-id>&SERVER-STATUS=400 443 - <ip-adress> Apache-HttpClient/4.5.5+(Java/1.8.0_202) - 400 0 0 493

This is preceeded by some 401 - unauthorized errors

in http.sys Log it says at the same time 

HTTP/1.1 POST /rest/mywork-client/1/host/verifyAuth - 411 - LengthRequired -

0 votes
Diego Atlassian Team Sep 22, 2020

Hello @Thomas Wohlwend !

As I understand, you are having problems to create Jira issues via Confluence.

I have seen this issue when we were accessing Confluence and Jira on the same server and they did not have distinct Context Paths. I suspect that you might be facing the same situation.

However, since I can not be sure about the affecting issue due to the lack of insight on your Confluence server, we should start by looking at the logs from Confluence to check what is happening. If you need more information on the logs, you can check our documentation on logs here:

Since the issue that you are currently facing is a known one, we have relevant documentation that aims at the solution for this. You can look at it here:

Please, let us hear from you!

Hi Diego, thanks for taking the time. 

Context path does not apply in my case. I work with subdomains, albeit on the same server. 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
6.15.4
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

109 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you