Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence CLI addLabels function doesn't add label to space

Hi,

I tried to use the addLabels function of Bob Swift's Confluence CLI client to automatically add a category/label to a space like this:

... --action addLabels --space "XYZ" --labels "some-label"

The verbose output returns http code 200 together with the message "1 labels added to space XYZ.", so no errors during the call, but if I want to review the results in the space details, I find that the label wasn't acutally attached to the space. The automation user has all space permissions and I also limited the test to existing labels, but nothing helped so far.

Can anyone help? Is this a bug?

 

Thanks and regards

Christian

1 answer

1 accepted

0 votes
Answer accepted

Hi @Christian Olschinka , 

We are from BobSwift support team. 

Yes, your action is correct. With the above cli command, the labels should get added to the space categories section in the Space Tools.

We have opened a Support Request 3293  for this issue. Could you please signup to our portal for further discussion on this ticket, 3293 ? As we need few more details to investigate the issue and ensure that the action is running as expected

Regards,
Amulya Akula

Hi @Amulya Akula _Appfire_,

thank you for your quick response. I have signed up to the portal, but cannot see the ticket you mentioned yet.

Regards

Christian

Hi @Christian Olschinka , 

Thank you for creating the request. Please access the support request, SUPPORT-3293,  now and let us know if you face any issues. 

Regards,
Amulya Akula

Hi @Christian Olschinka ,

We see that you are using the CLI client v8.0.0 and the server url as https://test.teamspace.rheinmetall.com/confluence

We would request you to please download the CLI Client v9.0.0 from this page.

Once you download, update the file and then execute the action, addlabels and let us know if this works.

--action addLabels --space "XYZ" --labels "some-label" --debug

Also, ensure that if the base url is https://test.teamspace.rheinmetall.com/confluence then the server parameter should also be https://test.teamspace.rheinmetall.com/confluence.

 

Regards,

Amulya Akula

Updating the CLI client from 8.0.0 to 9.0.0 solved the problem.

 

Thank you

Christian

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

323 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you