Confluence: After update to 7.0.1, impossible to edit page

tony crescence September 19, 2019

Hi,

We updated our confluence to 7.0.1 but we cannot add new page. When we want to add new page or modify existed page , we can't edit the page.

Here the message:

"Your request could not be processed because a required security token was not present in the request. You may need to re-submit the form or reload the page."

Can you provide us a solution?

Thanks in advance for your return,

 

Best regards

1 answer

0 votes
Stephen Sifers
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
September 20, 2019

Hello Tony and welcome to the Community!

Congratulations on making the upgrade to Confluence 7.0.1, but sorry to hear you’re running into an issue updating and creating pages. From the help error that you posted, it looks like your impacted by a token issues which is fixable. Please see the following on how to proceed:

Problem

A Confluence user is unable to add a comment to an attachment in a page. Each time the save button is clicked, an error message 'Your request could not be processed because a required security token was not present in the request. You may need to re-submit the form or reload the page.' is displayed. This affects all users and all attachments.

Diagnosis

Try to perform the following steps to see if the issue persists before proceeding with the resolution:

  • Clear browser cache
  • Bypass proxy and use IP address to access Confluence
  • Disable XSRF Protection for adding comments
  • Check modified files via Confluence Admin >> System Information and revert the modifications (if exists)
  • If all the steps above don't help resolving the issue, trace the network with Firefox's Firebug, Chrome's Developer tools, or the same tools while replicating the issue. If the first POST message is immediately responded by 403 (forbidden) error, proceed with the resolution.

Cause

There are modified files in Confluence installation directory. These files are most likely located in <Confluence-Installation>/confluence/pages directory.

Resolution

Revert all the modification done in the following files:

<confluence-installation>/confluence/pages/confirmattachmentremoval.vm
<confluence-installation>/confluence/pages/confirmattachmentversionremoval.vm
<confluence-installation>/confluence/pages/editattachment.vm
<confluence-installation>/confluence/pages/handlenameconflicts.vm
<confluence-installation>/confluence/pages/viewinfo.vm
<confluence-installation>/confluence/pages/panels/reorder-page.vm

Restart Confluence

Source documentation: https://confluence.atlassian.com/confkb/unable-to-add-a-comment-to-an-attachment-with-required-security-token-was-not-present-error-600115060.html

Please let us know if the above helps to resolve the issue and if you’re able to make your edits and creates again.

Regards,
Stephen Sifers

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