Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,131
Community Members
 
Community Events
168
Community Groups

Confluence API copy page causing 404 error

Edited

Trying to make a copy of a single page within the same confluence space using the API as exemplified here.

I'm getting this 404 error:

"null for uri: https://docs.my.company.com/rest/api/content/491102008/copy","status-code":404}'

My python code:

import requests
from requests.auth import HTTPBasicAuth
import json

url = 'https://docs.my.company.com/rest/api/content/491102008/copy'
headers = {'Content-Type': 'application/json',
"Accept": "application/json;charset=UTF-8"}
auth = HTTPBasicAuth('username', 'password')
payload = json.dumps({
"destination": {
"type": "space",
"value": "MYSPACE"
},
})
response = requests.post(url, headers=headers, data=payload, auth=auth)
response.raise_for_status()
return response

 

I've tried copying many different pages with different ids and a couple different spaces without changing the error.

The URL 'https://docs.my.company.com/rest/api/' has worked for my other API functions, as does my 'headers' and 'auth' parameters.

My company's instance of confluence is version 7.4.3

2 answers

1 accepted

2 votes
Answer accepted
Thomas Deiler Community Leader Oct 21, 2021

Dear @Woodson Miles ,

welcome to the community.

The endpoint 

GET /rest/api/content/{d}/copy

does not exist in the rest api reference. That's why it doesn't work. You are referencing to the CLOUD Api. Server is different.

To do what you want, you need to call first

GET /rest/api/content/{id}

read the page body, modify and then create with:

POST /rest/api/content

So long

Thomas

ok, so this is not about the API, but REST API and therefore not what I was looking for...

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events