Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence 6.10.1 Server Install: Error connecting to MSSQL DB with Windows Authentication.

Hi I'm receiving error: "SQL State - 08S01 com.microsoft.sqlserver.jdbc.SQLServerException: This driver is not configured for integrated authentication.."

From this article (https://community.atlassian.com/t5/Confluence-questions/Confluence-MS-SQL-Server-connection-with-Microsoft/qaq-p/691948), it looks like the issue could be the JDBC driver bundled with Confluence. I can't locate the sqljdbc_auth.dll file that is mentioned in the article on my server, so I'm wondering if the bundled JDBC driver installed properly.

Should I manually re-install it? If so what version should I install? I have downloaded version 7.0 which is the latest 'Type 4' driver from MS. The Atlassian docs say only a specific version of the Type 4 driver is supported, but do not advise which version that is (https://confluence.atlassian.com/doc/database-jdbc-drivers-171742.html).

 

NB: If I drop the "integratedSecurity=true" from the connection string I get error code - 18456 with message: "Login failed for user" when trying a test connection. In the SQL server logs I get error: "Login failed for user.. Reason: Attempting to use an NT account name with SQL Server Authentication".

Also, I can test-connect fine using a SQL server-based user, just not a user with Windows authentication. I need to use Windows Auth however for my deployment.

 

Cheers,

Nick

 

1 answer

1 vote

Hi Nicholas,

Both 7.0 and 6.0 drivers are type 4, so I don't see a reason why it shouldn't work.

I would make sure there is configuration done based on Microsoft's documentation.

  • Download and extract sqljdbc_auth.dll from Microsoft JDBC Driver 7.0 for SQL Server
  • If you are running a 64-bit JVM on a x64 processor, copy the sqljdbc_auth.dll file to the x64 folder.
  • Add the following to the JVM argument and restart Confluence in order for it to use sqljdbc_auth.dll -
    -Djava.library.path=C:\Microsoft JDBC Driver 7.0 for SQL Server\sqljdbc_<version>\enu\auth\x64
    

Please check our documentation on Configuring System Properties for more details.

If 7.0 doesn't work please feel free to try 6.0.

Regards,

Shannon

Thanks Shannon. I installed the JDBC 7.0 driver and that seems to have fixed the issue for me.

 

 

Cheers,

Nick

Nick,

Glad to hear you were able to get it working.

Let us know if you have any additional issues.

Regards,

Shannon

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence Cloud

Please tell us how you use Confluence space settings

👋 Hi there, a few of us at Atlassian would love to learn about how you use "space settings" functionality in Confluence. A facelift to the space settings is long overdue and we want to start with im...

112 views 5 5
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you