Confluence 6.0.1: Loading the editor's taking longer than usual

Since migrating to 6.0.1, we see this error preventing users from editing pages seemingly randomly.

confluence-edit-bug.png

I was told this is a known bug in 6.0.1, so my question is will this be fixed in 6.0.2 and how long until 6.0.2 is released? Also, is there a workaround for it in 6.0.1?

3 answers

Hi I just changed one system property and it worked for me.

In file <Confluence home>\confluence.cfg.xml I changed synchrony.proxy.enabled property to false

Documentation


this way not works for me

This worked for me. I'm running v6.0.3. Thanks Roman.

This worked for me. v6.03. Roman U rock!

I'm running Confluence on Windows and I don't have a confluence.cfg.xml file. Could it be in another file?

Chris, I'm running on Windows too. Try to use search file!

Of course I did that. wink
The problem is your description above is ambiguous. On my install, I have 2 paths:
C:\Program Files\Atlassian\Application Data\
C:\Program Files\Atlassian\Confluence\

Since your path says <Confluence Home>\, I searched in C:\Program Files\Atlassian\Confluence\ and found nothing. But once I went one directory back, I found the file in C:\Program Files\Atlassian\Application Data\Confluence.

Since your hint above doesn't mention there are TWO Confluence paths, it was easy to mistake the first one as the root. (I should also add I didn't use a custom install and I followed the defaults, so this is Confluence's fault! :smile )

Hope this comes in handy for someone else. The tip worked right away, once I found the file!

Chris. I used Atlassian notation of JIRA/Confluence directories. Installation dir and Home dir are not the same and can be even placed on different servers. 

C:\Program Files\Atlassian\Application Data\ - Confluence home dir

C:\Program Files\Atlassian\Confluence\ - Confluence install dir

Thanks for your comment! I didn't noticed that this info is not obvious.

Well, if I had searched in the c:\program files\Atlassian directory in the first place, I would have found it. smile

See the https://answers.atlassian.com/questions/43893571. The workaround can be simple, if you are not using https otherwise you need to proxy your instance.

We're not currently using https, so is the issue a firewall issue (base on the post you linked)? And if we were using SSL, how would that differ?

So yes the issue is connected to your firewall. If you used ssl, read the https://answers.atlassian.com/questions/43893571 (links to a comment). You will have to place an nginx/apache in front of confluence and proxy all requests

Daniel, Panos: I'm running Confluence 6.0.1 on a Windows Server 2012 R2 VM w/o https and have the same problem (internal use only). I added an inbound firewall rule to Windows Firewall for 8091 and the editor still does not load for me. Only option is for me to disable Collaborative Editing so the editor will work. Was there something else I need to open up?

The workaround worked for me when i restarted the synchrony. Did you also open ports from vm firewall? Finally, inspect the connection from your chrome/firefox to see exactly the connection properties

@Panos Karampis Got it working. I had tried restarting Synchrony before i posted and it still wasn't working. WHich is when i decided to disable it so I could get some work done. After reading your post, i turned Collaborative editing back on, Synchrony started, and voila - CE is working. Many thanks to you! laugh

It took me a while to find this here. I have nginx terminating SSL and Confluence behind it, and still, this doesn't work. The synchrony health checks in the log indicate it's able to connect just fine. For now, I have disabled collaborative editing.

I dont know about health checks. Open the chrome inspection console. What errors do you see?

@Giovanni Tirloni, try to change proxy property as I suggested in my answer below.

@Evan Barash . I am running the same set up as you Windows 2012 VM. Could you tell me how you got it to work? Currently It only works correctly for me with Edge/IE users.

thanks.

@Steven Parsons First I created an Inbound Rule to open 8091 for Synchrony (or whatever port your running Synchrony on) on my VM hosting Confluence, then restarted Synchrony service in services.msc and Collaborative Editing still wasn't working. So i decided to turn off CE entirely, restarted my VM (just for good measure), then turned on CE and that seemed to work. I probably didn't need to reboot, but I figured the 30 second wait was worth a shot. And it works in any browser, Chrome, IE/Edge, Firefox, etc.

Thanks, I don't think its an issue with my firewall. I have run tests with it disabled. My issue is with the IIS rewrite rules that are being used to proxy requests.

not yet. I've just upgraded confluence from 5.10 to 6.0.2. AND... have discovered this inconvenient bug.

Are there plans to fix it in 6.0.3 ? 

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

628 views 21 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you