It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Configuring multiple User Directories

We would like to automatically assign users (on first login) to the correct access group based on a property in the AD Directory.  I have setup 2 directories that are the same except:

- in the first directory I assigned object filter with term "(!(employeeType=Vendor))" with automatic group assignment to groups "regular" and "confluence-users"

- in the second directory I assigned object filter with term "(employeeType=Vendor)" with automatic group assignment to groups "vendor" and "confluence-users"

I had a regular user login and they were correctly added to the "regular" group.  However, when I had a vendor login, they successfully logged in, though they were not added to either group.

When I look at the user record, it does show they were found correctly in the 2nd directory.  What do I need to fix to have them added to the desired groups?

1 answer

This was actually working correctly.  My vendor had not actually completed successful login as the cause of the problem.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
6.13.4
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

8,477 views 6 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you