Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Comments marked resolved due to text deletion but not actually deleted

Hi all,

I keep having an issue with Confluence where when the page gets published, Confluence will mark some comments as "resolved" and note the reason for it as someone from our team deleted the text. The problem is... no one is deleting or copy and pasting the text. It even listed me as someone who deleted text, but all I did was add text.

To add to the issue, because Confluence thinks the text was deleted, it won't let me reopen the comment thread.

Is anyone else having this issue and, if so, are there any known fixes for this?

2 answers

I just had this exact situation happen to me yesterday, including being unable to reopen the resolved comment in question. I was doing a review of all comments in a longer confluence doc, and was saving after each edit/resolution. I was the only one editing the page at that time, and found that the resolved comment was on text I had not touched at all during my edits. 

I have not seen it happen in any other pages so far, but I've informed my teams to keep an eye on their comments. I'm using Chrome (v86), as well. 

Thanks for sharing! It makes me feel a little better that it's not just unique to us. Hopefully this is something they'll resolve soon as it's causing issues in our document development process.

We've been using action items to cope with this bug where we can, but that's not always possible.

0 votes
Diego Atlassian Team Oct 12, 2020

Hello @Brenda Hoyle !

As I understand, inline comments are being marked as resolved due to the fact that Confluence interprets text as being removed from the page. This also causes the comments to get stuck in the resolved status because the original text was supposedly removed.

I tried to replicate this but was able to reach the same results only when actually removing all the original text from the page at once.

I have created this page with highlighted text (either with bold or the comment highlight) describing what I did to each specific piece of text that contained a comment:

Screen Shot 2020-10-12 at 16.57.03.pngScreen Shot 2020-10-12 at 16.57.39.png

Removing all commented text excerpt at once and then adding the exact same text back does not bring the comment back because we essentially deleted the original text and then added new text that is written as the original, but is not the original.

With this in mind, I would like to ask you a few questions. Here we go:

  1. Could you describe in a step by step manner, how was this behavior triggered on your side?
  2. Is this affecting all pages containing inline comments that you edit?
  3. Is this happening regardless of the browser you use while editing the page?

Let us hear from you!

Hi Diego, 

Thanks for looking into this!

  1. I've noticed the problem happens in the longer documents we work on when there's multiple people in the document at the same time, making edits in different sections. 
  2. I have not noticed this happening in the smaller pages we have.
  3. I use Google Chrome. 

For context, we're working on gov't papers, so the document ends up being quite long. Different people on our team are assigned different sections so at no point are they editing my sections. However, when my teammates make additions to their sections and publish the page, I'll get an email stating that they deleted and readded my section (on top showing me they added text to their sections) even though I was adding to that section that entire time and nothing was deleted.


@Diego Any updates on this? It's been almost a month and a half since I first posted about this issue.

Diego Atlassian Team Nov 18, 2020

Hello @Brenda Hoyle!

Thank you very much for keeping this thread alive. I am sorry for not coming back earlier. I was able to find the following report:

Atlassian is currently working to solve this issue. The best course of action would be to keep an eye there to check when the issue is solved.

Also, there is this another report about copying and pasting content with inline comments:

Let me hear from you!

@Diego Thanks for sharing these. However, these don't address the main issue which is that Confluence is assuming we are deleting or copy/pasting content in the first place. What can you tell me about how this is being addressed?

Like Diego likes this
Diego Atlassian Team Nov 26, 2020

Hello there @Brenda Hoyle ! That is something I have been trying to replicate but am unable to. However, I found this report:

Would it be possible for you to try and replicate the behavior when all your browsers addons are disabled (if any) or using another browser?

 

Let us hear from you.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

218 views 0 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you