Collaborative editing not working Edited

Hi

I have upgraded to Confluence 6.3.3 and cannot edit pages in Collaborative mode. I get this message

This page is taking longer to load than usual. Give it a few moments, then try refreshing. Still having issues? Contact your Confluence admin.

and errors in the atlassian-synchrony.log file:

Having failed to acquire a resource, com.mchange.v2.resourcepool.BasicResourcePool@78480584 is interrupting all Threads waiting on a resource to check out. Will try again in response to new client requests.
com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask@4679804a -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (30). Last acquisition attempt exception:
java.sql.SQLException: ORA-00604: error occurred at recursive SQL level 1
ORA-01882: timezone region not found

        at oracle.jdbc.driver.T4CTTIoer11.processError(T4CTTIoer11.java:494)
        at oracle.jdbc.driver.T4CTTIoer11.processError(T4CTTIoer11.java:441)
        at oracle.jdbc.driver.T4CTTIoer11.processError(T4CTTIoer11.java:436)
        at oracle.jdbc.driver.T4CTTIfun.processError(T4CTTIfun.java:1061)
        at oracle.jdbc.driver.T4CTTIoauthenticate.processError(T4CTTIoauthenticate.java:550)
        at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:623)
        at oracle.jdbc.driver.T4CTTIfun.doRPC(T4CTTIfun.java:252)
        at oracle.jdbc.driver.T4CTTIoauthenticate.doOAUTH(T4CTTIoauthenticate.java:499)
        at oracle.jdbc.driver.T4CTTIoauthenticate.doOAUTH(T4CTTIoauthenticate.java:1279)
        at oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:663)
        at oracle.jdbc.driver.PhysicalConnection.connect(PhysicalConnection.java:688)
        at oracle.jdbc.driver.T4CDriverExtension.getConnection(T4CDriverExtension.java:39)
        at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:691)
        at com.mchange.v2.c3p0.DriverManagerDataSource.getConnection(DriverManagerDataSource.java:175)
        at com.mchange.v2.c3p0.WrapperConnectionPoolDataSource.getPooledConnection(WrapperConnectionPoolDataSource.java:220)
        at com.mchange.v2.c3p0.WrapperConnectionPoolDataSource.getPooledConnection(WrapperConnectionPoolDataSource.java:206)
        at com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool$1PooledConnectionResourcePoolManager.acquireResource(C3P0PooledConnectionPool.java:203)
        at com.mchange.v2.resourcepool.BasicResourcePool.doAcquire(BasicResourcePool.java:1138)
        at com.mchange.v2.resourcepool.BasicResourcePool.doAcquireAndDecrementPendingAcquiresWithinLockOnSuccess(BasicResourcePool.java:1125)
        at com.mchange.v2.resourcepool.BasicResourcePool.access$700(BasicResourcePool.java:44)
        at com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask.run(BasicResourcePool.java:1870)
        at com.mchange.v2.async.ThreadPoolAsynchronousRunner$PoolThread.run(ThreadPoolAsynchronousRunner.java:696)

I have added already the timezone to the setenv.sh but it doens't help for the synchrony server:

CATALINA_OPTS="-Duser.timezone=Europe/Zurich ${CATALINA_OPTS}"

Could anyone give me some support for this?

 

Thanks

3 answers

Hi Andrea,

we updated yesterday to 6.3.2 Version and had the same problem. In our case the cause was the apache version.

 

https://confluence.atlassian.com/confkb/confluence-collaborative-editing-does-not-work-with-ssl-and-apache-2-4-9-or-earlier-872132268.html

 

Probably you have this problem?

There is a known issue when upgrading Confluence with an Oracle database. Oracle users should upgrade their driver to 12.2.0.x before upgrading to Confluence 6.1 or later. See Upgrade to version 6.1.x Failed With Error "ORA-01000: maximum open cursors exceeded" for more information. 

 

Probably this could help.

Regards

Julia

Hi Julia

Thanks for your reply. We're using the standalone version of Confluence, so Apache shouldn't be the issue. We're using ojdbc8.jar an the database itself is 12c as recommended by Atlassian. What version are you on?

Regards
Andrea

Hi Andrea we are using postgreSQL9.5.8 not Oracle.

Unless it's a typo, the second double quote in the timezone setting should be moved. It looks like you have:

CATALINA_OPTS="-Duser.timezone=Europe/Zurich ${CATALINA_OPTS}"

Where it should be:

CATALINA_OPTS="-Duser.timezone=Europe/Zurich" ${CATALINA_OPTS}

I am hopeful that this will be the answer, as this similar error that happened on a JIRA instance was solved by setting the time zone: Jira SW 7.1.1 does not connect to Oracle DB

Hi Ann

I have enhanced the already existing list, out of the box after installation, with this line and all others do have the same syntax I've used.

CATALINA_OPTS="-XX:-PrintGCDetails -XX:+PrintGCDateStamps -XX:-PrintTenuringDistribution ${CATALINA_OPTS}"
CATALINA_OPTS="-Xloggc:$LOGBASEABS/logs/gc-`date +%F_%H-%M-%S`.log -XX:+UseGCLogFileRotation -XX:NumberOfGCLogFiles=5 -XX:GCLogFileSize=2M ${CATALINA_OPTS}"
CATALINA_OPTS="-XX:G1ReservePercent=20 ${CATALINA_OPTS}"
CATALINA_OPTS="-Djava.awt.headless=true ${CATALINA_OPTS}"
CATALINA_OPTS="-Duser.timezone=Europe/Zurich ${CATALINA_OPTS}"
CATALINA_OPTS="-Datlassian.plugins.enable.wait=300 ${CATALINA_OPTS}"
CATALINA_OPTS="-Xms1024m -Xmx1024m -XX:+UseG1GC ${CATALINA_OPTS}"
CATALINA_OPTS="-Dsynchrony.enable.xhr.fallback=true ${CATALINA_OPTS}"
CATALINA_OPTS="-Dorg.apache.tomcat.websocket.DEFAULT_BUFFER_SIZE=32768 ${CATALINA_OPTS}"
CATALINA_OPTS="${START_CONFLUENCE_JAVA_OPTS} ${CATALINA_OPTS}"
CATALINA_OPTS="-Dconfluence.context.path=${CONFLUENCE_CONTEXT_PATH} ${CATALINA_OPTS}"

Before I have added this line, Confluence didn't even start, but it is working now except the Synchrony part. It looks like the Synchrony server instance must have its own catalina settings or something like this.

Regards
Andrea

Ann Worley Atlassian Team Aug 25, 2017

You are absolutely right and I have to apologize as I trusted a random forum for the syntax instead of checking my own setenv.sh.

To pass arguments to Synchrony, please create a file called synchrony-args.properties in the Confluence home directory as described in: Change your Synchrony configuration

Hi Atlassians,

The version we have upgraded to is v6.2.4

I do have the same problem with "Collaborative Editing". I requested my linux admin to open the port 8091 to have Collaborative editing feature work properly. I have followed below link and made sure first 3 steps are fine. During step#4 from the link below I am getting an issue.

https://confluence.atlassian.com/confkb/unable-to-edit-any-pages-in-confluence-6-x-due-to-collaborative-editing-867362716.html

Along with this I am now unable to launch the application itself after port 8091 is opened. Getting below error.

========================================

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /.

Reason: Error reading from remote server

========================================

Do I need to add any changes in setenv.sh or server.xml file or https.conf after the port 8091 is opened ?

This is a showstopper for us to continue with the UAT Testing.

 

Thanks a log in advance !!

Best Regards,

Nav

Hi Nav

Our problem was only the timezone missing in the configuration, so Oracle didn't start at all.

This is how our server.xml is looking but we're using a reverse proxy in front of Confluence. I don't know if it's correct for everyone, but in our environment is it working properly.

Regards
Andrea

 

<Server port="8005" shutdown="SHUTDOWN" debug="0">
    <Service name="Tomcat-Standalone">
    <!-- Apache Proxy Connector with values for scheme, proxyName and proxyPort -->

<Connector
            protocol="HTTP/1.1"
            port="8445"

            maxThreads="150"
            minSpareThreads="25"
            connectionTimeout="20000"
            disableUploadTimeout="true"
            acceptCount="100"

            enableLookups="false"
            maxHttpHeaderSize="8192"

            useBodyEncodingForURI="true"
            URIEncoding="UTF-8"

            secure="true"
            scheme="https"
            proxyName="confluence.mydomain.com"
            proxyPort="443"
/>

        <Engine name="Standalone" defaultHost="localhost" debug="0">

            <Host name="localhost" debug="0" appBase="webapps" unpackWARs="true" autoDeploy="false" startStopThreads="4">
                <Context path="" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true">
                    <Manager pathname="" />
                    <Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60" />
                </Context>

                <Context path="${confluence.context.path}/synchrony-proxy" docBase="../synchrony-proxy" debug="0" reloadable="false" useHttpOnly="true">
                    <Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60" />
                </Context>
            </Host>

        </Engine>
    </Service>
</Server>

Hi,

I have got the same problem after upgrade our Confluence Server to version 6.4.1.

You can work around by navigate to <base URL>/admin/darkfeatures.action and remove:
site-wide.synchrony
site-wide.synchrony.opt-in
site-wide.shared-drafts

Our Confuence is running behind firewall and my solution for this problem is adding these to installation-directory/bin/setenv.sh:

Dhttp.nonProxyHosts=localhost\|127.0.0.1

Dhttps.nonProxyHosts=localhost\|127.0.0.1

 

Cheers,

Anh Le

Ouch, no, you do NOT want to remove those files, they exist for a reason.  The proxy lines are ok to get it working, but do hint that you may have a poorly configured firewall.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Tuesday in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

416 views 18 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you