Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Code Snippet not displaying outside of edit mode

Not much info to provide beyond what the title says. When I am in editing mode, I select code snippet, it creates a little section for code to be written into, I paste my code, It displays the code I just pasted in the code section, with lines and everything. When I hit publish, the code snippet simply disappears completely. When I hit edit, the code returns. It's simply not displaying in the actual wiki. I don't expect every person reading my wiki pages to do so in edit mode, why is this issue occurring?

 

I've tried googling the issue, but google refuses to give me any results that aren't to do with the code block feature that the code snippet apparently replaced. Please understand that I am not asking where this old feature went, I am not asking why the code block feature has disappeared. I am asking why this new feature, the code snippet, does not display anything while in view mode, yet displays just fine in editing mode.

1 answer

0 votes

Hi @Carter Hill , I have been using the code snippet and it works fine in viewing. I just tested it.

 

In my test, I just inputted a print statement and choose groovy as the language and publish it. I also modified to Java and it was there. 

 

I'm not aware of a feature option that restrict the viewing of it. 

Thank you for the response.

 

Upon opening confluence this time around, the code snippets seem to load in just fine. Very strange behavior, no changes were made to the code I originally wrote in or the snippet settings. I am viewing it from the web version on Firefox, maybe Firefox has some issues with it.

I'm glad to have made a post about it at least, so there's some evidence of a problem like this popping up. Would love to have known what solved it though lol. Might be something the dev team has to look into if this problem arises for anyone else.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Confluence

Miss the Confluence demos at Team 21? Watch them here!

Phew, Atlassian Team 2021 blew by. With dozens of demos and a handful of keynotes, you may have missed some of the awesome Confluence Cloud sessions. Don't' worry, you can watch them all here or on Y...

298 views 2 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you