Chrome dosen't load macro preview

I have Confluence 6.6.0 installed and one strange thing I have seen is that Macro preview dosen't load in Google Chrome. (same problem at 6.5.1 and 6.5.2 too)

I thought it didn't suppose to load in first place but when I happend to use Firefox one day then Macro preview loaded in one second.

 

Is anyone else facing same problem?confluence_preview.PNG

1 answer

1 accepted

0 votes
Accepted answer

Hi Gen,

  1. Does this occur for all macros?
  2. What version of Google Chrome are you using? 
  3. Does the same occur in Incognito Mode?
  4. What about when all add-ons are disabled?
  5. Lastly, can you check the Confluence Server Application Logs to see if you see any error messages? 

Regards,
Shannon

  1. Yes
  2. Version 64.0.3282.71
  3. Yes
  4. Still the same
  5. Anything dosen't pop-up

Gen,

I assume you have also tested this from multiple workstations?

The latest stable version of Chrome is 63.0.3239.132. Can you confirm the issue on that as well?

Please also use Developer Tools > Network in Chrome and let us know what error messages show there.

It will also help if you try completely clearing your Chrome cache.

Regards,
Shannon

Yes, I have tested with multiple workstations.

Error occurs at latest stable Chrome aswell. I am running beta.

I attached images.confluence_preview_debug.pngconfluence_preview_debug_works.png

Gen,

Is that 2nd image from Firefox? 

Could you tell us, do you happen to be behind a reverse proxy? Is there any special NGINX configuration?

I found another customer that had the exact same error, and they found that their NGINX configuration was set X-FRAME-OPTIONS = "Deny" which caused the issue.

If you have this setup you have a look at those settings and let us know if you find anything like that? 

You will want to make sure it's setup the way like in the link above.

Regards,

Shannon

Gen,

This article also goes over a similar fix:

Gliffy Not Loading

Let me know if you have any trouble!

Shannon

I have fixed the error with extra webserver parameter:

add_header X-Frame-Options "server address";

Great Gen! Thank you for confirming that.

Glad the information I provided was able to assist in resolving the issue.

Take care, and Kind regards,

Shannon

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,017 views 14 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you