Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Child pages not displaying correctly in Children Display macro

Alan Vickers July 29, 2022

We are having issues with child pages that are displayed on parent pages in the Children Display macro. Regardless of the number of child pages, only the first four are displayed. We are using the default settings (we are not setting any limits). 

ChildPages.png

4 answers

1 vote
Bill Bailey
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
July 29, 2022

@Alan Vickers A few things to test out/debug:

  • Try setting a Number of Children to see if you can make more appear?
  • If that does nothing, try changing the sort order to see if the list changes?
  • Check the page to make sure the macro is not inside some other macro (or pasted HTML) that might limit the display.
Alan Vickers August 2, 2022

Thanks @Bill Bailey . We have tried all the above with no luck. 

0 votes
Nicolai Sibler
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
August 2, 2022

Hi @Alan Vickers ,

does everybody see 4 children only on the parent page's macro output?

I'm asking because of a specific phenomenon:

As a Confluence Administrator, you'll see the complete page tree in the sidebar in any case. But on the page, you'll only see the macro output as a user. So if there are page restrictions on the pages 5-x and you as a user are not added to these restrictions, the macro will show you those 4 pages only. The users added to the page restrictions will have a different count of pages they see on the parent page.

Kind regards,

Nicolai

Alan Vickers August 2, 2022

Thanks @Nicolai Sibler. Everyone sees 4 children only, and it is present in all wikis spaces (we have over 100). 

Nicolai Sibler
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
August 4, 2022

I think this is worth raising a support ticket at Atlassian.

From my experience, I suspect that the support team will first require some further testing to isolate the cause of the problem.

This includes

  • Rebuilding the index from scratch
  • Running in safe mode (without 3rd party apps)
  • Without customizations (Custom HTML etc)
Like Alan Vickers likes this
Alan Vickers August 4, 2022

Thanks @Nicolai Sibler

Good info. Our IT team submitted a ticket. Again, appreciate the help!

Like Nicolai Sibler likes this
Nicolai Sibler
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
August 5, 2022

You're welcome. Kindly inform us about the solution here.

Solomon Putla September 4, 2023

@Alan Vickers In which version is this issue seen?

We were on 7.19.2 and upgraded to 7.19.12. After upgrade, we started seeing this issue. Any feedback from vendor? Please share.

Alan Vickers September 5, 2023

Hi @Solomon Putla This was a response from the Confluence team that ultimately resolved our issue:

Thank you for updating us! In this case, I was checking data from your support zip file and I found this:

<confluence.child-macro.max-depth>4</confluence.child-macro.max-depth>

<confluence.child-macro.page-limit>4</confluence.child-macro.page-limit>

Dconfluence.child-macro.page-limit=4 exit abort -Xms7000m -Xmx12000m</virtual-machine-arguments>

[flag.png]Maybe in the past this configuration has been made by an admin and was not documented for future reference:

JVM option below on a personal lab to limit the number of children shown by the macro, and it worked fine for me (set to 4, on this example):

CATALINA_OPTS="-Dconfluence.child-macro.page-limit=4 ${CATALINA_OPTS}"

Just so you have at hand, you can also set a maximum number for 'Depth of Descendants':

CATALINA_OPTS="-Dconfluence.child-macro.max-depth=4 ${CATALINA_OPTS}"

0 votes
Fabio Racobaldo _Herzum_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
July 30, 2022

Hi @Alan Vickers ,

probably you set Number of Children on your macro. Remove that entry on macro configuration. It should solve your issue.

Fabio

Alan Vickers August 2, 2022

Thanks Fabio. This is set to blank. 

0 votes
Florian Bonniec
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
July 29, 2022

Hi

 

Can you share how you configured the macro ?

There is a Number Of Children Parameter that should be empty or may be set to 4 in your case.

Alan Vickers July 29, 2022

Hi Florian. Thanks for the quick response. We are leaving the default settings:

 

ChildPageConfig.png

Florian Bonniec
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
July 29, 2022

@Alan Vickers Have a look to @Bill Bailey  recommendations.

 

It may be related to ancestor table also even if I think that it would have not display the pages on the right also.

 

https://confluence.atlassian.com/doc/rebuilding-the-ancestor-table-153948.html

Alan Vickers July 29, 2022

Thanks Florian! I'll take a look. 

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events