It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Chart Macro Rendering Issue (preview fine)

Hi there,

I am currently fighting with the chart macro to have the data displayed properly.

When I managed (I think) to display the data as I wanted, the preview in the macro works fine.

For information, I use a Page Property Reports as data for my chart.

When I save the macro and publish the page, the chart is not displaying...

Any idea?

Many thanks

5 answers

There is a change request regarding the problems we are facing:

https://jira.atlassian.com/browse/CONFCLOUD-51867

hopefully it will get enough attention...

0 votes

Hey, hello there Julien!

Have you tried to check the same page with another browser or even a different machine? We could try this and rule out the browser or your computer as the root of this behaviour.

  • Try another browser
  • Try the browser's incognito mode
  • Try another machine

Further, could you clarify a few points for us? Here they are:

  1. Has this worked at some point in the past?
  2. Is this affecting other pages as well?
  3. Are other addons displaying as expected?
  4. Is there any kind of error displayed when you publish the page?

 

One last thing! Are you on Confluence Cloud or Server? You can more easily identify them based on the sidebars. Here they are:

Confluence Cloud:

Screen Shot 2019-05-06 at 18.01.45.png

Confluence Server:

Screen Shot 2019-05-06 at 18.03.32.png

 

Also, could you share a screenshot of what you see when you publish the page? Just be careful not to display any sensitive information with this screenshots. Our Community is an open space and as such, anyone can see everything posted here.

 

Looking forward to your reply Julien!

Hi Diego, thanks for your reply.

I have tried another browser, private mode, and another machine. The result is still the same.

 

  • Has this worked at some point in the past?
    • This is the first time I try to to that
  • Is this affecting other pages as well?
    • I don't know as it is the first time I try
  • Are other addons displaying as expected?
    • As far as I know yes
  • Is there any kind of error displayed when you publish the page?
    • No

We are using Confluence Cloud.

This is the preview I get in the macro preview viewer.

Screenshot 2019-05-08 at 11.36.44.png

When I publish the page, I could send you a screenshot but basically Nothing is displayed.

Although if I choose to display graph data before or after, it displays the table of data when I publish the page, but still not the graph.

 

Thanks!

I am experiencing the exact same issue, also in Confluence Cloud.

The only difference is that my graph makes use of a table in an excerpt-include from another page. At the moment the table is filled with test data, so nothing sensitive to see here :)

I have tried adding the table directly into the chart (instead of using the excerpt-include), but the result was the same. 
The reason I am trying to get this to work is so that our Scrum-master only has to update one table and that all charts and graphs will change.
If we can't get this to work, he has to change 4 charts and the big table after every sprint.

See the screenshots below:

Source table:

source_table.pngChart preview:

chart_preview.pngPage in edit mode:

page_edit_view.png

Page after publishing:

page_after_publish.png

Funny enough I am trying to display the exact same kind of data :)

Like Bas_Witte likes this

Any other suggestion @Diego_Canto_Rodrigues ?

Chart macro is not compatible with macros, that produce tables dynamically. Page Properties Report (PPR) is one them:

  • In the macro preview PPR outputs the table as static content on the server side. So when the chart is rendered for the macro preview on the server, it gets the PPR table.
  • When you view the page, PPR outputs no table, then it makes a request to Confluence server, receives the tables in the response and attaches it to the page using javascript. So in this case the chart has no data when it is rendered on the server.

As a workaround you can use Chart from Table macro (Table Filter and Charts app) that is compatible with dynamic macros and PPR as well. This macro builds charts on the client side, that's why it works properly with such macros.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

283 views 9 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you