Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,462,771
Community Members
 
Community Events
176
Community Groups

Cannot publish page - keep getting error

Edited

Since Tuesday I haven't been able to publish any page on Confluence. I keep getting the same error "There was an error processing the request."

Screen Shot 2017-08-18 at 16.35.35.png

What is causing this problem? Is anyone else having the same issue?

I've tried everything, including creating a new page and copy-pasting the content in. Nothing worked.

 

 

14 answers

Strangely enough I was able to work around this issue by

  1. Selecting everything on the page (Ctrl+A)
  2. Copying and pasting it right back in place (Ctrl+C then Ctrl+V)

Then I was able to save, no problem.

I hope this works for you too.

Thank you very much, this worked for us as well!

Deleted user Mar 13, 2018

Worked for me too.

Brilliant, worked for me too.

Yup!  worked for as well -moments ago. super annoying so really appreciate the ez pz work around.

Time saver! Thank you!

Hi Nick,

Great! It worked for me as well. 

Awesome - thanks - worked for me too!  That's been bugging me for a few weeks - just on once page!

Chiming in to say this also just worked for us, although it makes no sense at all...Thanks!

Holy crap, it works!

I have too much to copy and paste i.e. tabs and expanding links and etch... has there been a fix put into place?

Amazing that Worked!

YES! Worked! Thank you! Saved my @$$!

Works like a charm, :D
Thank You!

strangely it did not work for me.

Like # people like this

unfortunately, that didn't work for me. instead, i copied the link to the confluence page i was editing, pasted it into a new tab in my browser, and clicked published. i then closed the first tab.

 

that worked. 

Like Trevan Householder likes this

I'm here to say that my changes are being auto-saved, but the publish button (or close, or options (...)) buttons are not working.  I've tried pasting into a new tab, and even creating a new page.  I am unable to publish anything at the moment.

@Benjamin Leff Your solution worked for me as well.  The others did not work for me (cloud).  Thanks!

This solution does not work for me.  Is there a fix?

Like Marlee Serrano likes this

The solution didn't work for me but I was inspired. I did Ctrl + X, refreshed the page, clicked edit (appeared to be an empty page), Ctrl + V, clicked publish, and this worked :)

Can Atlassian fix this issue?  stop releasing low-quality product and keep adding features that are not useful.

I know this is an old topic, and I'm not sure about my answer... but the page I'm having trouble with has a ton of @ mentions for folks who no longer work with us.  I suspect every one of those has higher overhead than if there's a real person for the @ mention -- for example, maybe Confluence isn't caching null responses while doing those lookups, so it's doing a lot more lookups than it should need to. 

(We're on Cloud and my team doesn't have access to logs, so I'm pretty far out on a limb with that idea.)

I went nuts with this issue. How can this still be a thing in late 2021?
Anyway, switching from Edge to Firefox and renaming the new page fixed my issue.

Same problem here. It is so frustrating!!!! None of the above mentioned solutions worked :(

I tried dividing the information, so from 1 page I made two ant it worked one time. After that I keep getting the same error.

---- I solved it by using another browser.

Changing the page name resolved it to me

Easier to open the same page in a new browser (should come up with 'Unpublished changes'), click edit and then save.

Cutting and pasting risks loss of formatting and data.

A coworker of mine had the same issue because his page name wasn't unique. Make sure you don't have page name duplicates.

Revert to the previous page version helped me.

Hi Fei Chen,

 

Please check if you can find the following trace in $confluence_home/logs:

com.atlassian.confluence.content.render.xhtml.XhtmlException: RuntimeException occurred while transforming editor format to storage format (null)

If the trace is there, we would recommend to check if  CONFSERVER-54133 affecting you.

0 votes
Fei CHEN Community Leader Jul 10, 2018

I hit the same problem too. I noticed that the update button worked after removed the user mention (@myname) from the draft. 

Env:

Confluence 6.6.2

Language: Chinese Simplified

My user name is in Chinese characters.

Fei CHEN Community Leader Jul 10, 2018

The user mention is in a section in page layout

Doesn't work for me since, I'm editing within a macro table. Any ideas on how I can do this method through my way?

Getting the same error message from today onwards :(

Have you had a look in the logfile? Sometimes the error message there is more verbose.

I have problems saving a page if there is a number of macros in a 'problematic' configuration (see Problem saving a Confluence Page?). But the error message I get is a little different. Nonetheless you may want to check it.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events