Cannot login after upgrade - troubleshoot authentication failures??

I attempted to upgrade from confluence 3.5.2 to 4.1.5. It starts up fine and I can get to the login screen but no matter what I do I cannot login. I've tried everything I can think of. There aren't any errors in the logs, that I can find, which would explain this. The log tells me that I failed to login but does not tell me why.

I even went through some steps I found on the confluence confluence :P for manually changing my password through SQL: http://confluence.atlassian.com/display/DOC/Restoring+Passwords+To+Recover+Admin+User+Rights

but this did not help.

I'm not using Crowd. I'm not using LDAP.

I have no idea why it's failing to authenticate me. It always worked before. Also, when I click the forgot password link, I'm told that I don't have a mail server configured and I do! I'm triple checked that my javax.mail.Session resource is in server.xml exactly like it's supposed to be, as is my javax.sql.DataSource resource for the database. The data source is referenced from data/confluence-cfg.xml just like it's supposed to be. I've verified that the username/password can connect to the database over localhost.

I've even tried changing the security log level in log4j.properties to DEBUG and it didn't give me any extra information. I have no idea what's wrong.

Any help would be greatly appreciated!

-John

1 answer

Hi John,

A stab in the dark, but you're not hitting this issue are you? - http://confluence.atlassian.com/pages/viewpage.action?pageId=230817988

Andrew.

It doesn't look like it. I'm using MySQL,

mysql> select directory_name,active from cwd_directory;
+-------------------------------+--------+
| directory_name                | active |
+-------------------------------+--------+
| Confluence Internal Directory | T      |
+-------------------------------+--------+
1 row in set (0.00 sec)

mysql>

I appear to have fixed the problem... Although I have NO idea why it worked. I was trying to figure out what was happening so I enabled the MySQL query log so I could see what queries were being executed, mostly just to confirm that they WERE being executed. At any rate, enabling the query log required a MySQL restart and after that I was able to log in.... It fixed it but I have no idea why.

It happened to me again a few minutes ago after a server restart while I was tweaking the mail server configuration. I think the MySQL restart was coincidental. All I had to do was wait a few minutes and I could log in again. It might be some kind of security lockout.

Joe Clark Atlassian Team Feb 20, 2012

Ff you have some kind of automated login hitting your Confluence instance with an old password (for example, an RSS Reader), you can very quickly hit the failed login limit and cause your account to become locked - could this be the case in your situation?

No. All I have is my web browser(Firefox). Although, the lockouts tend to coincide with server restarts.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,554 views 25 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you