Cannot install gliffy plugin

While trying to install the gliffy plugin (10 user license) I get the following error:

An unexpected error occurred. Please refer to the logs for more information.

The audit log shows the following:

Failed to install add-on plugin.8540658440628312576.gliffy-confluence-plugin-5.4.jar

This is a brand new installation and confluence itself is functioning properly. Any tips on how I should troubleshoot and make the plugin installable would be much appreciated.

The Universal Plugin Manager (v2.9.0) by Atlassian

I cannot update the UPM either (to v2.12)

7 answers

1 accepted

1 vote
Accepted answer

Hi Jeffrey,

Can you take a look at the Confluence log file (<CONFLUENCE_HOME>/logs/atlassian-confluence.log) and see if there is a specific error mentioned?

Have you tried downloading the plugin from the marketplace and uploading it manually (manage add-ons -> upload plugin on the right of the screen)?

I tried upgrading Gliffy to 5.4 yesterday and encountered a problem with my MySQL db configuration (max_packet_size). The default Confluence documentation states a value of 32MB for the max_packet_size is sufficient, however the latest version of the Gliffy plugin seems to be 32,2MB large. It is best to set this variable to a higher value, the how to can be found here: https://confluence.atlassian.com/display/CONFKB/Exceeds+Max+Allowed+Packet+for+MySQL.

Cheers,

Tom

That's what I figured out too. But that still is the wrong way to store it. The data can be stored in chunks instead, eliminating the need to up the max_packet_size to suit different plugins sizes.
0 votes

HI Jeffery,

First thing you need to do is to check your Server Base URL https://confluence.atlassian.com/display/DOC/Configuring+the+Server+Base+URL. The UPM will not work if the Server Base URL is not configured properly.

If you have confirmed that the Server Base URL is correct, the next step is trace the atlassian.confluence.log in your <confluence-home/data>/logs directory.


Based on the logs, look for the error that are similar to the one of the KB below. The resolution is included in the document as well.

https://confluence.atlassian.com/display/CONFKB/UPM+or+add-on+update+fails

https://confluence.atlassian.com/display/CONFKB/Unable+to+Install+Plugins

https://confluence.atlassian.com/display/CONFKB/UPM+Cannot+be+Upgraded

My Server Base URL looks like:

&lt;Context path="" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true"&gt;
                    &lt;!-- Logger is deprecated in Tomcat 5.5. Logging configuration for Confluence is specified in confluence/WEB-INF/classes/log4j.properties --&gt;
                    &lt;Manager pathname="" /&gt;
                &lt;/Context&gt;

Should the path attribute contain a slash?

I think I may know what the problem is. I am using Apache mod_proxy to delegate to confluence localhost:8080 Will have to check the proxy configuration.

Hi Jeffery,

Since you are using a apache mod_proxy, you need to configure the server base url in the Confluence to be the same as the URL that you use to access the Confluence page.

For example, the URL that you used to access confluence is http://example.com/. You will need to set the Server Base Url in the Confluence Admin >> General Configuration >> Server Base URL to match the URL http://example.com/.

Hope this helps.

Jing,

I have the base URL setup properly.

Here is my setup in detail:

I have two Servers:

Server 1 (local ip 192.168.1.247) has Apache2

Server 2 (local ip 192.168.1.248) has Confluence (port 8090) + JIRA (port (8080)

My Router delegates port 80 to Server 1

Server 1 has Virtual Host with mod_proxy configured to delegate Confluence domain to Server 2 port 8090

Even after changing the base URL to 192.168.1.248:8090 and accessing confluence at http://192.168.1.248:8090, I was not able to update/install the plugin.

Hi Jeffery,


If that is the case, we will need to gather more information from the logs. You can report this issue in https://support.atlassian.com/ so we can perform a proper investigation on this issue.

Kind Regards,
Jing Hwa

@Tom I have already tried manual download and install and updated the max_packet_size, both didn't make a difference.

@Jing, I will raise an issue at support.atlassian.com

In the end max_packet_size was the problem. I had upped it to 32MB already from the defaults. But even that was not enough. The size of the plugin itself was over 32MB. Upping the max_packet_size to 64 fixed the problem. I woudn't have known this until I downloaded the plugin manually and compared to the error which was thrown.

I don't understand why the max_packet_size should be that high to install a plugin. To me it sounds like the max_packet_size needs to be higher than the overall size of the plugin. Maybe a bad design choice in the installation of the plugin?

Hi Jeffrey, thanks for accepting my answer, I updated it a bit to reflect the reason why.
In Confluence, plugins are installed in the database itself (table plugindata if I'm correct). Since the whole binary should be put in this table, the value needs to be this high, by design of Confluence.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,085 views 17 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you