Cannot Edit a Comment Confluence 5

Just upgraded to Confluence 5.0.2 and now I am not able to edit a comment. There is no problem posting or deleting a comment.

When attempting to edit a comment, the editor comes up but you are not able to click in the body to start typing. You can hit any button on the editor toolbar, but no matter what you do no content is added.

I have checked permissions, tried different themes, and both IE and FF.

6 answers

This widget could not be displayed.

Hi Evan,

First and foremost, please ensure that all of your third party plugins are compatible with your current Confluence 5.0.2. Incompatible third party plugins could lead to many weird issues. Secondly please try to clear plugin cache and see how it goes.

Hope it helps.

Cheers,
Septa Cahyadiputra

I cleared the plugin cache and still no luck. Let me go through all my plugins tomorrow and make sure they are all compatible. There may have been some unknown ones. If so I'll disable them one by one and see if one of them is the culprit.

I checked and the plugins "should" be compatible. I also took out some custom HTML to show the newest comments on top:

<script> AJS.toInit(function(){ $comments = AJS.$('#page-comments'); $comments.children().each(function(i,li){$comments.prepend(li)}) });</script>

However I am still having no luck.

In order to further investigate this issue, I highly recommend you to create a support ticket on our support channel so we could review your logs privately. It would be hard for us to further investigate this issue if the following causes has been excluded without reviewing your logs:

  • Plugin cache corruption, resolve by clearing the plugin cache
  • Incompatible third party plugin, resolved by enabling plugin safe mode
  • Reverting back any customization to default

If you don't mind to attach your atlassian-confluence.log which is located in <CONF_HOME_Dir>/logs/ into this public channel, we can review it from here. If you don't want it to be available in public site pelase proceed to create a support ticket.

We would be more than happy to assist you trough it.

Cheers,
Septa Cahyadiputra

Just wanted to let everyone know that I also tried turning of safe mode and testing. I had the same result. I do have a ticket on this issue as well now.

This widget could not be displayed.

Benu Gupta said:

I was able the resolve the edit comment issue in Confluence 5.1.5 by removing the javascript code from Custom HTML under Administration -> LOOK AND FEEL. Not sure if its the same issue for you as well.

That was the answer - I found custom code in there, deleted it and editing comments works.

Thanks!

This widget could not be displayed.

FYI, I put Confluence in safe mode and got the same result. So it is not a third party plugin causing the issue.

Here is my ticket number if anyone else has this issue and wants to track:

This widget could not be displayed.

I am experiencing a similar issue with Confluence 5.1.5. Is there a resolution yet or a workaround?

This widget could not be displayed.

I am using Confluence 5.1.2.

I noticed that only Admins can edit comments. Are users able to edit comments if they have 'add/remove' rights in a Space?

I would like to assign specific users the ability to do this. Does anyone know if this is possible?

In order to edit comments you need to have Administer permission at the Space level. Anybody can edit their own comments.

This is not a permissions issue: Confluence is displaying the edit comment dialog, it just doesn't work (the dialog)

This widget could not be displayed.

Try turning off the Atlassian Quick Edit plugin and see if you can edit comments after that.

Are there any javascript errors in your browser when you click in the editor?

If you right click the unclickable body and inspect element, how much does the HTML look like this?

&lt;iframe id="wysiwygTextarea_ifr" src='javascript:""' frameborder="0" allowtransparency="true" title="{#aria.rich_text_area}" tabindex="100" style="width: 100%; height: 150px; display: block;"&gt;

&lt;html style="overflow-y: hidden;"&gt;

&lt;head xmlns="http://www.w3.org/1999/xhtml"&gt;&lt;base href="http://localhost:62014"&gt;&lt;meta http-equiv="X-UA-Compatible" content="IE=7"&gt;&lt;meta http-equiv="Content-Type" content="text/html; charset=UTF-8"&gt;

… lots of links and styles …

&lt;/head&gt;

&lt;body id="tinymce" class="mceContentBody aui-theme-default wiki-content editor-comment" onload="window.parent.tinyMCE.get('wysiwygTextarea').onLoad.dispatch();" contenteditable="true" dir="ltr" style="overflow-y: hidden;"&gt;&lt;p&gt;&lt;br&gt;&lt;/p&gt;&lt;/body&gt;&lt;/html&gt;&lt;/iframe&gt;

You mentioned IE and FF have you tried in chrome?

I have the same problem, Confluence 5.5.

When I right click on the unclickable body and do inspect element, it appears significantly different to yours. I have the wysiwygTextArea iframe, but the contents do not look similar:

element details

... this is Chrome 35.0.1916.114 m on Windows 7

I was able the resolve the edit comment issue in Confluence 5.1.5 by removing the javascript code from Custom HTML under Administration -> LOOK AND FEEL. Not sure if its the same issue for you as well.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Tuesday in Confluence

Add-on evaluation with confluence templates

Atlassian market place contains number of Apps/Addons which improves the capability of out of the box Atlassian products. It is good to follow a plugin evaluation process before install add-ons. So t...

75 views 9 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you