Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,256,534
Community Members
 
Community Events
164
Community Groups

Cannot Add Inline Comment to Plain Text using Chrome

When I want to add an inline comment to plain text I get the following error message: “We can’t add your inline comment; the section you
highlighted may contain a macro or user mention. Try highlighting plain text.”
It is definitely plain text and the storage format looks ok.

The error is non-deterministic and occurs only when using Chrome.

I see the following error in the JS console:
POST https://XXXXXX.com/rest/inlinecomments/1.0/comments 412 (Precondition Failed)
XMLHttpRequest.send @ batch.js?analytics-e…r-enabled=true:9271

 

Thanks in advance.

 

Best regards,
Steve Strauch

1 answer

1 accepted

0 votes
Answer accepted
Shannon S Atlassian Team Nov 12, 2018

Steve,

Can you tell us how many words you selected when you attempted the inline comment? Was the selection in another language, and are you able to leave inline comments on other sections?

Secondly, what version of Confluence are you using?

Thank you!

Shannon

@Shannon S thanks for your answer.
I selected the first word of a bullet point that is in bold. The bullet point contains more text.

The Confluence Version is 6.6.3.

Thanks.

Cheers,
Steve

Shannon S Atlassian Team Nov 27, 2018

Thank you Steve,

I was finding the issue was happening with short two-letter words as well, so I wanted to verify.

It appears that you have run into a bug that has since been resolved in Confluence 6.12.0:

When you're ready to upgrade, you can go straight to 6.12.0 and your issue should be resolved.

If you have any questions about that process, feel free to let us know.

Regards,

Shannon

Hi @Shannon S

thank you for your support.
I marked a five-letter word when I got the error message.

You are right. Thanks for pointing to the bug report.

Best regards,
Steve

Shannon S Atlassian Team Nov 28, 2018

Steve,

No problem at all! Happy to be able to connect you to the proper bug report.

Take care, and kind regards,

Shannon

Hi Shannon,

We are already on confluence 7.11.1 version but we still have this issue. 

Like Jaan Pärtna likes this

We are on Confluence 6.13.10 and also face this issue. Any further advise or help available?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence Cloud

Presenter Mode for Confluence is here 🖥 👩‍💻

👋  Hello Community!  My name is Stephanie Zhang, and I’m a product manager on the Confluence cloud team. Today, I’m excited to announce the rollout of  Presenter Mode : a ...

2,307 views 19 41
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you