Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can we upgrade confluence server from 3.5.16 to 6.15.8??

Hi Team,

I have a confluence server 3.5.16 in Server A(This is windows 2008R2 server) , can i install confluence server 6.15.8 in Server B(This is windows 2016R2 server) and move the contents from one server to another as this document suggests https://confluence.atlassian.com/doc/migrating-confluence-between-servers-184150.html .Please suggest what steps to take im new to confluence.

 

Regards,

Abhishek B A

1 answer

1 accepted

0 votes
Answer accepted

No.

3.x has a totally different storage format and data structure to 4.0 and above and you need to upgrade to a version that can still understand the old data so it can upgrade it.

You should upgrade from 3.x to 4.latest first.  Then thoroughly test a 4.x to 6.target upgrade (In theory, this can work, but I've seen it have problems).  If it fails, then plan 4.x to 5.latest, then 5.x to 6.target - that should work ok.

Hi @Nic Brough _Adaptavist_  , after i upgraded from  3.5.16 -> 4.2.7  when i start confluence im getting the below error for all plugins(below shows only one plugin error) , do you have any suggestions on how to resolve the same .

 

2019-09-26 05:26:24,306 ERROR [main] [atlassian.plugin.loaders.ScanningPluginLoader] deployPluginFromUnit Unable to deploy plugin 'com.atlassian.confluence.extra.widgetconnector', file Unit: D:\confluence\data\bundled-plugins\widgetconnector-2.0.1.jar (1340412696000) java.lang.IllegalStateException: Unable to create a tracker when osgi is not running

Have you upgraded all the plugins as well?

Hi @Nic Brough _Adaptavist_  can you please guide me on how can we upgrade the plugins in 3.5.16? or you can share me a link for the same .

You should visit the "manage plugins" section in admin and work through installing the latest version of each plugin you have.

Hi @Nic Brough _Adaptavist_  we are getting the following error when we upgraded from 4.3.7 to 5.0.3 it looks like some plugins issue can you pls guide me .I have attached the screen shot for the same .

 

Also @Nic Brough _Adaptavist_ in 3.5/4.2.7/4.3.7/5.0.3 we are not able to find manage add-ons/manage plugins  in admin page .Confluence_Error.PNG

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

342 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you