Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't edit my pages or edit any thing! Emergency help!

I have updated my confluence to 7.11.0

Collaborative editing is on!  

Everything work ok! But I can't edit my pages; I get this problem!

Cause

org.springframework.jdbc.BadSqlGrammarException: Hibernate operation: could not execute statement; bad SQL grammar []; nested exception is com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: PROCEDURE confluence.content_procedure_for_denormalised_permissions does not exist
    at org.springframework.jdbc.support.SQLStateSQLExceptionTranslator.doTranslate(SQLStateSQLExceptionTranslator.java:101)

caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: PROCEDURE confluence.content_procedure_for_denormalised_permissions does not exist
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

 

Please help me how to solve the problem because I need to change sensitive information on my site otherwise it will cost me alot if not changed! 

3 answers

0 votes
Dominic Lagger Community Leader Feb 16, 2021

Hi @Netset 

  • When did you get this message? 
  • When you log in, when you save a page or when you want to edit a page? 
  • Does it occurs on any page or just some special pages?
  • Are you the only one with this problem? 

The error message says something like there is a problem with the encoding in the database. 

Here is a similar post: installation error BadSqlGrammarException Hibernate operation 

Regards, Dominic

Hi,

 

I get this message when I tried upgrade Confluence from 7.10.2 to 7.11.0 With Database in mysql in docker!

Then I took abckup of the datbase from mysql in docker and restored it to mariadb installed in Linux CentOS 7! The upgrade worked fine then. I could even upgrade 7.11.0. to 7.11.1 in database in mariadb. I repeated the upgrade procedure again with db in mysql in docker I get the same message. 

the tables recovery twice then I get that about  nested exception is com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: PROCEDURE confluence.content_procedure_for_denormalised_permissions does not exist

in confluence_home/logs/atlassian-confluence.log

Note: If I upgrade from 7.10.2 to 7.11.0 with mariadb (not in docker) it works fine.

If I take backup  from the upgraded version from mariadb and restore it to mysql (in docker)

then confluence 7.11.0 works fine (Confluence with DB in mysql docker)

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.11.0
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

198 views 0 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you