Can't create or edit page

I am having an issue where I am unable, as an administrator, to edit or create pages in Confluence. I have checked global and page permissions and have full rights. I am afraid I may have some sort of installation problem (it is locally hosted on my server). I listed severity as minor though it is pretty much useless at this time - however, this is only being evaluated so don't need priority support.

I am checking to see if this is something recognizable that may be due to a configuration problem before I do a re-install. Please note that I also have Jira installed on the same server and have no issues adding or editing content on Jira.

6 answers

1 accepted

John,

Thanks for your input, your issue is the same I pointed above. Based on the stack trace you pasted, MySQL is not able to find the DIGEST column since it probably failed to create it.

That being the case, please try running the ALTER TABLE statement from this page: https://confluence.atlassian.com/display/CONFKB/Unable+to+Create+Pages+or+Spaces+after+Upgrading+to+3.3

If the above does not work, you may try the ones on this KB: https://confluence.atlassian.com/display/CONFKB/%27exception+setting+property+value+with+CGLIB%27+in+Logs+when+Using+Edit+in+Word+or+Trying+to+Save+a+Page

Be sure to take a database backup prior to changing anything. I'm hoping that Brian is experiencing the same issue, so he can also follow this same approach.

Cheers

Any error messages in the UI or the logs?

Any customizations or third party plugins?

Have you checked the space permissions? Does it hapen in every space?

Brian,

Adding to the above questions, can you confirm which Confluence version you're running? There's an old issue where users are unable to create pages/spaces after an upgrade to Confluence 3.3 that I've seen happening in earlier versions as well (i.e 3.5.*). Can you confirm that might be the case?

Hope it helps.

Hi Brian,

Its a bit though without getting more information in regards to the symptom. However if the symptom is editor frame is not accepting any input, plugin-cache corruption might be the cause of the issue. Please try the following steps and see how it goes:

  1. Shutdown Confluence
  2. Remove the following directories
    • <tt><confluence-home>/bundled-plugins</tt>
    • <tt><confluence-home>/plugin-cache</tt>
    • <tt><confluence-home>/plugins-osgi-cache</tt>
    • <tt><confluence-home>/plugins-temp</tt>
    • <tt><confluence-home>/bundled-plugins_language</tt>
  3. Rename atlassian-confluence.log located in <confluence-home>/logs/
  4. Restart Confluence

If the issue persist, please review the new atlassian-confluence.log and see if there are any ERROR indication that might explain the issue. You can provide us the stack trace as well and hopefully we would get more clue to investigate your issue from there.

Cheers,
Septa Cahyadiputra

I have the same issue... after upgrading from 3.0 to 3.5.

The atlassian-confluence log reports:

org.springframework.jdbc.BadSqlGrammarException: Hibernate operation: Could not execute query; bad SQL grammar []; nested exception is com.mysql.jdbc.exceptio
ns.jdbc4.MySQLSyntaxErrorException: Unknown column 'notificati0_.DIGEST' in 'field list'
Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Unknown column 'notificati0_.DIGEST' in 'field list'

I really should have followed the link and tried the suggested solution in the first place! Problem solved.

Thanks Alyson.

Sorry, I went ahead and reinstalled - must have had a corrupt install because it worked after I reinstalled. Since it was a test system, that seemed easiest. Thanks for the suggestion. Alyson 'll mark your answers since it seemed to work for John.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,180 views 20 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you