Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can not start synchrony service. Edited

I can enabled Confluence Collaborative Editor Plugin, but can't get the configuration page to start the service.

It simply errors out, but not much information for troubleshooting.

Any hint to troubleshoot would be greatly appreciated.

Thank you for help.

1 answer

1 accepted

0 votes
Answer accepted

Hi @teisyun 

Which version do you use for confluence server? You tagged version 4.7.1, but collaborative editing is available only from version 6.0.

Did you mean 7.4.1? Did you check this documentation?

What do you mean by "errors out", can you share a printscreen?

Regards, Dominic

Hi Dominic,

Thank you for your reply.

Sorry, the version was a typo, it is actually 7.1.0.

When I enable the plug-in and go the configuration page, it simply show like the screenshot, and I can't do anything about it.

When I check the log file, there was nothing about synchrony, and the service is not started.

I'm stuck...

confluence_error.PNG

Dominic Lagger Community Leader Nov 17, 2020

Ok, this is strange and the cause could be anything...

Here is a list, what you can check: 

I would check: 

  • Check you can edit a page
  • Check the logs
  • Restart Synchrony

Let me know if this helped.

Thanks Dominic,

My question is how to restart Synchrony other then from the Collaborative Editing configuration page, as it is not responding...

There is no log for Synchrony, as the service is not started.

Thanks,

Dominic Lagger Community Leader Nov 18, 2020

This is tricky

  • Did you try to restart confluence completely? 
  • Did you try to use another browser or incognito mode? 
  • Is there any log in the atlassian-confluence.log file? 

Perhaps this helps:

Regards, Dominic

Hi Dominic,

Really appreciate your help!

I have tried all I could think of, include deleting the pid file and clearing the cache folders, and the pid file won't get recreated, as I can't start the synchrony.

only thing can be found in the atlassian-confluence.log is "cannot connect 8090" which is because the synchrony is not running.

is there any configuration files that I can delete to restore synchrony to default setting?

If there is not other way to fix it, I will try to reinstall the confluence, hope it will overwrite existing configuration.

What do you think?

Thanks,

Dominic Lagger Community Leader Nov 22, 2020

Hi @teisyun 

Now, if you tried everything, I've also no clue what the problem is...

Perhaps, it would be good to go to the atlassian support:

https://support.atlassian.com/contact/#/

Log in and create a support ticket.

Regards, Dominic

@Dominic Lagger 

Again, thank you for your help.

FYI, it turned out that the above error was because the "Synchrony Interop Bootstrap Plugin" wasn't enabled.

Someone disabled the Collaborative Editing plug-in, which also disabled the Synchrony Interop Bootstrap Plugin, but when re-enabled the Collaborative Editing, it didn't also enable the Synchrony Interop Bootstrap Plugin, so it was left as "disabled"

After re-enabling the Synchrony Interop Bootstrap Plugin, everything now is working again.

Like Dominic Lagger likes this
Dominic Lagger Community Leader Nov 23, 2020

Hi @teisyun 

I'm happy for you that now everything is working fine! 

Regards, Dominic

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.1.0
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

125 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you