Can access Confluence remotely, but not JIRA

I have set up a domain and think I have done all the steps necessary to access my home server from the web, except I cannot access jira. For example, 192.168.0.10:8080 works within my network at home, but when I try to use the domain I set up, example.com:8080, I cannot access JIRA, it returns "webpage unavailable" or "chrome could not connect". The strange thing is that I can access confluence at example.com:8090/confluence. I've checked the url settings in JIRA, I've forwarded the ports, etc. Any ideas?

15 answers

This widget could not be displayed.

It looks like you have your 8080 port was already configured for some other service at your remote network setup. I cannot give you more info without investigation of your network settings, but seems that change of the port from the default 8080 to 8081 helped.

This widget could not be displayed.

Please provide more details on how do you set up the connection. If you have access to confluence using that scenario, please try example.com:8080/jira example.com:8090/jira

This widget could not be displayed.

I have setup a CNAME on my host to point to a dynamic dns account which forwards to my home public IP. This seems to all be working. I then forward the port 8080 to my server IP address just like I did with 8090 for confluence. example.com:8080/jira returns "chrome could not connect..." and example.com:8090/jira returns a blank page.

This widget could not be displayed.

The strange thing is that you have set up /confluence context path - you should set up it additionally as it is not the part of default installation. How can you access to confluence using the ip address? does the 192.168.0.10:8090/confluence lead to the start confluence page?

This widget could not be displayed.

Thanks for your help by the way. Yes it does. I added /confluence because I was following "Here be Dragons" tutuorial found here: https://confluence.atlassian.com/display/ATLAS/Dragons+Stage+3+-+Install+Confluence

This widget could not be displayed.

If you have set up port forwarding correctly - there should not be an issue. Please try to remove your setting for confluence - maybe it contains some conflict with the jira setting.

This widget could not be displayed.

I just removed the /confluence from config.xml and now I can't access either jira or confluence remotely. I can't access confluence locally, either. I wonder why they have /confluence in the tutorial?

This widget could not be displayed.

so now your jira and confluence can be accessed with local ip, but not your domain? Could you provide exact steps and tools you use to configure port forwarding and set up your domain? (with and without context)

This widget could not be displayed.

There is no need in context for default installation. so you should be able to follow the simple installation guide and set up confluence https://confluence.atlassian.com/display/DOC/Confluence+Installation+Guideand have access locally. You should get both apps accessed locally before you do some dns changes - to localize the problem.

This widget could not be displayed.

No I can't access confluence locally. I don't know what that affected changing the context path.

This widget could not be displayed.

Ok now it appears confluence can be accessed locally and remotely, I apologize, I forgot to start the confluence script after editing config.xml. Is there a good way for me to start over with the confluence installation at this point?

This widget could not be displayed.

If you have everything working - no need in new installation. We should check what is the problem with jira now. So you have jira accessed locally, but not remotely. Could you please give the info regarding the tools and steps you use to make jira accessed remotely.

As a temporary solution (just came into my head) try to change port from 8080 to 8081 for example and make proper forwarding. Please tell me if port change helped.

This widget could not be displayed.

Ok. When I change the port do I just have to change the base URL in the dashboard or do I have to change the configuration files too?

This widget could not be displayed.

yes and yes - you should configure inside configuration files and you have to change base url on administration board after jira reboot

This widget could not be displayed.

That does appear to have connectivity. I might just keep it like that, unless there is a reason to use 8080 only. Thanks for your help!

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Tuesday in Confluence

Add-on evaluation with confluence templates

Atlassian market place contains number of Apps/Addons which improves the capability of out of the box Atlassian products. It is good to follow a plugin evaluation process before install add-ons. So t...

141 views 12 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you