Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

CORS Issue in Marketplace after Upgrading to Confluence Data Center 7.4.14

Edited

After upgrading my Confluence Data Center instance to 7.4.14, I am getting CORS errors on the "Manage apps" screen when expanding some of the plugins on my instance.  You can see the issue here:

https://www.screencast.com/t/fXA565cj

As you can see, it looks like a request is getting blocked from the following URL:

https://marketplace.atlassian.com/rest/2/addons/com.adaptavist.confluence.contentFormattingMacros/pricing/server/live?countryCode=FI

I have already tried adding a whitelist for the marketplace.atlassian.com domain, which you can see here:

Img1.jpg

I have also added the following the following modification to the web.xml file (as suggested here):

<!-- MBZ: Added CORS Headers -->
<filter>
<filter-name>CorsFilter</filter-name>
<filter-class>org.apache.catalina.filters.CorsFilter</filter-class>;
<init-param>
<param-name>cors.allowed.origins</param-name>
<param-value>https://www.atlassian.com,https://marketplace.atlassian.com,https://support.member.buzz,https://www.member.buzz,https://resources.member.buzz,https://files.member.buzz</param-value>
</init-param>
<init-param>
<param-name>cors.allowed.methods</param-name>
<param-value>GET,POST,PUT,DELETE</param-value>
</init-param>
<init-param>
<param-name>cors.exposed.headers</param-name>
<param-value>Access-Control-Allow-Origin,Access-Control-Allow-Credentials</param-value>
</init-param>
<init-param>
<param-name>cors.support.credentials</param-name>
<param-value>true</param-value>
</init-param>
<init-param>
<param-name>cors.preflight.maxage</param-name>
<param-value>1800</param-value>
</init-param>
</filter>
<filter-mapping>
<filter-name>CorsFilter</filter-name>
<url-pattern>/*</url-pattern>
</filter-mapping>

 

1 answer

@William Yeack Try unchecking the setting "Connect to the Atlassian Marketplace" on the Manage Apps page. 

 

Screen Shot 2021-12-17 at 1.58.09 PM.png

Hi @Sundar Radhakrishnan - so I went back to check and the problem seems to have been resolved.  I am guessing that the Atlassian wasn't giving the right headers on their side and then they fixed things?

@William Yeack Looks like that. When I was facing the same issue this morning EST, saw errors on the browsers' console related to CORS when our local Jira app was calling marketplace API to fetch the plugin's info.So, they could have added XSS related headers in the response and set it to block. Or they would've enabled CORS at their backend (API or at the firewall side) and removed it.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.4.14
TAGS
Community showcase
Published in Confluence Cloud

🏠 Say hello to the new Confluence Home!

Hi Atlassian Community, My name is DJ Chung, and I’m a Product Manager on the Confluence Cloud team. Today, I’m excited to share a new and improved version of Home. The new Home helps you ...

963 views 7 42
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you