It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Building Confluence docker container fails (libc6-compat)

I've followed the recipe here: https://confluence.atlassian.com/confkb/update-the-confluence-docker-image-to-use-oracle-jdk-829062521.html

Building works fine until step 13. Here I get the following error:

(4/29) Installing libc6-compat (1.1.18-r3)
ERROR: libc6-compat-1.1.18-r3: trying to overwrite lib/ld-linux-x86-64.so.2 owned by glibc-2.27-r0.
ERROR: libc6-compat-1.1.18-r3: failed to rename lib64.apk-new to lib64.

Any suggestions? I'm up for testing whatever to make this work!

2 answers

1 accepted

3 votes
Answer accepted
Dave Chevell Atlassian Team May 03, 2018

Hi Snorre,

 

That error message suggests that your Dockerfile still includes the commands to install libc6-compat library. This should be removed from the list of libraries to be installed - from the doc you linked:

Within the same Dockerfile, remove the lib6-compat library as it is already in the above anapsix image. Also re-order the update-ca-certificates command as such:

  • RUN apk update -qq \
        && update-ca-certificates \
        && apk add ca-certificates wget curl openssh bash procps openssl perl ttf-dejavu tini libc6-compat \
        && rm -rf /var/lib/{apt,dpkg,cache,log}/ /tmp/* /var/tmp/*

    to

    RUN apk update -qq \
        && apk add ca-certificates wget curl openssh bash procps openssl perl ttf-dejavu tini \
        && update-ca-certificates \
        && rm -rf /var/lib/{apt,dpkg,cache,log}/ /tmp/* /var/tmp/*

If it's still not working for you after making this change, can you post your Dockerfile contents here?

 

Cheers,

Dave

The container built successfully. One warning was thrown when updating the CA-certs: "WARNING: ca-certificates.crt does not contain exactly one certificate or CRL: skipping", but I can live with that. I'll set up a container stack once I get home from work, to see if the lack of libc6-compat affects the running of the container.

Hey Snorre,

I should clarify: the base image already has libc6-compat installed. This is actually why you got the initial error - the binary trying to be installed already existed. So your container still includes this library, and you should see no ill effects related to removing that line from your Dockerfile. 

Cheers,

Dave

Ah! Well, the application is running smoothly now, working on building Bitbucket, and then it's onto Jira. Hopefully I'll have all three up and running by the end of the weekend. :) Thanks for the help!

Hi Snorre,

Try deleting the package in another step and then re install

apk del libc6-compat

I just tried this, still gave the same error. :(

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published Thursday in Confluence

Confluence CVEs and common questions

Two vulnerabilities have been published for Confluence Server and Data Center recently: March 20, 2019 CVE-2019-3395 / CVE-2019-3396 April 17, 2019 CVE-2019-3398 The goal of this article is...

253 views 0 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you