Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Auto insertion of Jira link in Confluence page not working Edited

I have experimented and found that only Chrome automatically inserts the "Insert JIRA Issue/Filter" macro when creating the Jira issue using the in-line operation.  Using Chrome we also successfully get the source Confluence page link in the newly created Jira issue at "Issue Links".  

IE11, Edge, and Firefox all return an error - "xxx-nnn has been created, but there is a problem in adding it to the page.
You can manually add it later using JIRA macro."

 

Also, the link to the originating Confluence page is not entered in the newly created Jira issue.

 

What can be done to fix this problem in those browsers?

---------------------------------------------

nevermind.  this is working for me now, except in Edge...  (I was mistakenly working with output from another macro - sql for confluence, rather than actual text on the page.)   Even though the jira issue filter insertion doesn't work, the issue is successfully created.  

 

This question came up because I had a user where this operation was not working in Edge, but it worked fine for them in Firefox.  

 

After looking closer, we were attempting to create a Jira issue highlighting text in a table that is inside a Table Filter macro.  Chrome, Firefox, and IE11 were successful, but Edge will not insert the Jira issue macro. 

 

3 answers

1 vote

Hi Al,

Thanks for providing so much detail around the issue you’re seeing. I believe you’re impacted by a known bug:

It’s interesting that you mention it works in most browsers, except Edge. In the comments on the bug, we see that the symptoms can sometimes be inconsistent, which we also see in your case.

Additionally, Microsoft Edge was not tested for versions of Confluence earlier than 5.10, so if you’re running an older version, that might be why you’re seeing inconsistencies.

Per the Atlassian Bug Fixing Policy, feel free to comment on the bug with how it’s affecting you! This provides more visibility into the issue for our development team.

We have Confluence 6.4.  Yesterday, the JIRA link was inserted correctly on an item inside a table in Edge (as long as the table filter macro was not wrapped around the table).

This morning we experienced the issue again.  On a different page we created a JIRA issue from text inside a table cell, but the JIRA link was not inserted.  The table was not wrapped inside any macro.  The item was formatted in a bullet list.  However, I removed the bullet and it still did not work.  The link was successfully inserted in FireFox.  

So, our work around is to simply not use Edge.  But, we would still like to understand why this does not work.  As you point out, the results seem inconsistent since it worked yesterday on a different page.  Upon closer inspection, the successful test was on a different instance of Confluence (also 6.4).  So, perhaps we have an option configured differently, or a different macro enabled, which interferes with this function.

0 votes
R. Fuerst Atlassian Team Jul 10, 2018

Hi @Al Genzlinger,

In order to appropriately investigate why this is occurring in one browser or page but not another, we'll need to gather more information. 

I've gone ahead and created a ticket with our support team to have them investigate further. You should see updates at your email used on Community. : )

A member of the support team will be in touch shortly with next steps.

Best,

Rachel

I have not been contacted yet regarding the details you need for investigation.

But, recreate steps should be very simple:

- create a table on a page

- wrap the table with table filter macro (https://docs.stiltsoft.com/display/public/TableFilter/Table+Filter+for+Confluence)

- highlight text and create jira issue from that text

Results:

- IE11, Chrome, and FireFox will add the Jira issue macro to the page.  Edge will not.

 

Separately, we have one instance of Confluence where this works with the table not inside the Table Filter macro, and another instance where it does not work.  I don't know what you need to determine the difference.  Both are at 6.4.

I had the exact same issue and was able to replicate in almost every browser. On trying out various options, I figured that if you have a hyperlink associated with the text on which you are creating a jira issue you will see the said error - "xx-nnn has been created, but there is a problem in adding it to the page. You can manually add it later using JIRA macro."

Just try to remove the hyperlink by editing the page or create jira issue on a normal text in the table, it should work. 

However, I would like to know how can we create a jira issue even though an hyperlink exists. Let me know if there is a way.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

383 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you