Attachments with umlauts inaccessable

Hi Team,

With our Confluence 4.0.4 we get a "file not found" error if we wan to access an attachement with german umlauts.

It turned out that it is definitely a proxy problem. After bypassing the proxy it works.

This is my proxy configuration.

<Proxy *>
Order deny,allow
Allow from all
</Proxy>

ProxyRequests   Off
ProxyPreserveHost       On
ProxyPass               /confluence     http://localhost:9092/confluence
ProxyPassReverse        /confluence     http://localhost:9092/confluence
AddLanguage de .de
AddCharset UTF-8 .utf8
AddDefaultCharset utf-8
AddCharset UTF-8 .action

Any Ideas how to find the solution?

THANKS

Philipp

For the records I also checked the following:

1.Formatting and International Settings:
Indexing Language German
Encoding UTF-8

2. Tomcat URI Encoding in Server XML:

<Connector className="org.apache.coyote.tomcat4.CoyoteConnector" port="9092" minProcessors="5"
                   maxProcessors="75"
                   enableLookups="false" redirectPort="8445" acceptCount="10" debug="0" connectionTimeout="20000"
                   useURIValidationHack="false" URIEncoding="UTF-8"/>

DB connection URL:
jdbc:mysql://mysql.myserver.com/confluence?autoReconnect=true&sessionVariables=storage_engine%3DInnoDB&characterEncoding=utf8

3. Database Encoding
Database Encoding:

mysql> use confluence404
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> status
--------------
mysql  Ver 14.14 Distrib 5.1.49, for debian-linux-gnu (x86_64) using readline 6.1

Connection id:		11916284
Current database:	confluence404
Current user:		hagenmanagement@0.0.0.0
SSL:			Not in use
Current pager:		stdout
Using outfile:		''
Using delimiter:	;
Server version:		5.1.49-3 (Debian)
Protocol version:	10
Connection:		mysql.myserver.com via TCP/IP
Server characterset:	utf8
Db     characterset:	utf8
Client characterset:	latin1
Conn.  characterset:	latin1
TCP port:		3306
Uptime:			320 days 1 hour 28 min 58 sec

Threads: 120  Questions: 814570352  Slow queries: 649  Opens: 1225141  Flush tables: 1  Open tables: 1024  Queries per second avg: 29.456
--------------

7 answers

How about try to remove the following and then try again:

AddCharset UTF-8 .utf8

AddDefaultCharset utf-8

AddCharset UTF-8 .action

FYI, you should apply the same URIEncoding parameter as above to the AJP connector if you are using mod_jk, and add the following option to your Apache mod_jk configuration:

<Connector port="8009" protocol="AJP/1.3" URIEncoding="UTF-8"/>
JkOptions +ForwardURICompatUnparsed

Probably set explicit AddDefaultCharset off to ensure your Vhost ist configured correctly (even it's the default value).

Related issue with mod_rewrite, fixed in Apache 2.2.12+:
https://answers.atlassian.com/questions/4790

Hi,

unfortunatelly I haven't the solution of your problem but I have the same problem. Did you solve it yet?

Thanks

Tomas

No. We have the same Problem with an IIS Proxy. Without Proxy OK, with Proxy the files are inaccessible because special chars are not encoded properly.

philipp

Hallo,

I didn't solve this problem. So I had to build completly new one server with Confluence as a single server with dedicated MySQL. Now it is working.

Best regards

Tomas.

Are you using a proxy? Which technique are you using? Could you show me your server.xml file?

Thanks

Philipp

Hi,

I'm using exactly the same configuration as in my previous server which wasn't working corretly.

So my Confluence is behind proxy created on Apache server and connected to the MySQL server. These servers are running on Win2008 server 64bit ENG.

Apache server configuration:

&lt;Proxy *&gt;
        Order deny,allow
        Allow from all
&lt;/Proxy&gt;

&lt;VirtualHost *:80&gt;
    ServerAdmin    admin@domain
    ServerName     confluence
    ErrorLog       "logs/confluence-error.log"
    CustomLog      "logs/confluence-access.log" common

    ProxyRequests  Off
    ProxyPreserveHost   On
    ProxyPass           /    http://localhost:8090/
    ProxyPassReverse    /    http://localhost:8090/
    
    &lt;location /&gt;
      Order deny,allow
      Allow from all
    &lt;/location&gt;
&lt;/VirtualHost&gt;

Then configuration on /conf/server.xml

&lt;Server port="8000" shutdown="SHUTDOWN" debug="0"&gt;
    &lt;Service name="Tomcat-Standalone"&gt;
        &lt;Connector className="org.apache.coyote.tomcat4.CoyoteConnector" port="8090" minProcessors="5"
                   maxProcessors="75"
                   enableLookups="false" redirectPort="8443" acceptCount="10" debug="0" connectionTimeout="20000"
                   useURIValidationHack="false" URIEncoding="UTF-8"/&gt;
        &lt;Engine name="Standalone" defaultHost="localhost" debug="0"&gt;
            &lt;Host name="localhost" debug="0" appBase="webapps" unpackWARs="true" autoDeploy="false"&gt;
                &lt;Context path="" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true"&gt;
                    &lt;Manager pathname="" /&gt;
                &lt;/Context&gt;
            &lt;/Host&gt;
        &lt;/Engine&gt;
    &lt;/Service&gt;
&lt;/Server&gt;

And my setting from app_data/confluence/confluence.cfg.xml:

&lt;property name="hibernate.connection.url"&gt;jdbc:mysql://localhost/confluencedb?sessionVariables=storage_engine%3DInnoDB&amp;amp;useUnicode=true&amp;amp;characterEncoding=utf8&lt;/property&gt;

For the server I have DNS record 'confluence' and Apache doesn't serve any other web page.

Let me know if you will need any other configuration detail. But I'm afrait it doesn't help you because this configuration is the same as on my previous server where it doesn't work correctly.

Best regards and good luck.

Tomas

Hi,

Tomas, thanks a lot for the detailed information!

Maybe Apache has a higher version-number on the new server?

Is it still possible to track that?

Best regards,

Philipp

Hi Philipp,

it's true. Now I'm using these softwares:

httpd-2.2.22-win32-x86-openssl-0.9.8t.msi
atlassian-confluence-4.3-x64.exe
mysql-5.5.25a-winx64.msi

On my previous server it was:

Apache-2.0.58
MySQL-5.1

But during the testing I had the same configuration on my another new one server where it was working even with the same versions. At the end I used the latest versions.

I spent a lot of time and power to try to solve this problem and I can say that my time is more expensive then the new one server. At the end I have the new one server dedicated just for Confluence and I'm happy with that.

BR

Tomas

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

897 views 23 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you