Attachments not showing in Viewfile macro

When I try to use the viewfile macro on some pages (not all which is strange) the macro will not pick up to show the attachments which could be viewed. ie within the macro parameters are the page (which is showing the current page) and the file to view (which should show the list of attachments to the page so that the correct one can be selected). In this case there are no options showing and hence it is not possible to use the macro.

Anyone else found this problem and know if there is an answer?

3 answers

Geoff, an alternative is to use Sharpview for Atlassian Confluence, which is quite popular. Provides a richer viewfile experience (feature-rich viewer; either flash-based or HTML5), but also it is only for PDFs. (The link has video and in-line example, since AppFusions website is built on Confluence.)

An evolved variation of that is AppFusions' document management integration plugins for Google Drive, Alfresco, Dropbox, Box,  Egnyte, <your flavor; let us know>. Here's a playlist of videos. In these solutions, you can navigate/embed folders, preview, embed docs, download, upload, and edit (in Office apps including MS Office, NeoOffice, OpenOffice) all from within Confluence ... and also uses the rich viewer of Sharpview. 

All of these are highly supported plugins, some since as early as 2010 (and through Confluence's many versions since then). We have customers running these that have renewed for years, with over 20K+ users on their corporate wiki. info@appfusions.com if you would like to try these.

0 votes

Hi Geoff,

This is awkward indeed. Do you see any error in the logs regarding attachments and the name of the affected pages?

Are you using the latest version of confluence? I could find some bugs that were fixed in the latest versions:

https://jira.atlassian.com/browse/CONF-35155

https://jira.atlassian.com/browse/CONF-34835

It might be a good idea to check in a staging instance with the latest version installed to check if that replicates;

Cheers,

Rodrigo

We are on v5.4.3 but there were no errors reported just that the macro failed to show any attachments. It is stranger than that as it only appears on certain pages. I can theorise that it depends on the parent page. I am creating new pages on which I wish to display the pdf (or word) attachment; so only the viewfile macro is being used. For some pages it will show the attachments (of the relevant type ie .doc .pdf etc) for others (well one other which I have found) it will not show anything. I have gotten around the problem by creating the page elsewhere and then moving it to where it should be, but it is a strange bug in the system! Maybe that helps?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Thursday in Confluence

What are your project planning tips?

Hello Community,  Jessica here from the Confluence product marketing team! Today I wanted to get your takes on project planning –– what works, what doesn’t, how do you know if you’re doing it r...

155 views 0 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you