Atlassian Google Doc Plugin error - solved

I've installed this on a staging site and it works fine. I created a production site, restored our information to the production site. When I try to connect using Google Docs OAuth it says:

You have successfully authorized access to Google Docs. Please go back to your previous page and refresh.

When I refresh the page, it says:

Unable to authorise access to Google Docs

The inserted Google doc on the production site says:

Error rendering macro 'gdocument' : : com.appfusions.confluence.googledoc.bean.OAuthTokenPair ---- Debugging information ---- message : : com.appfusions.confluence.googledoc.bean.OAuthTokenPair line number : 1 path : /com.appfusions.confluence.googledoc.bean.OAuthTokenPair cause-message : : com.appfusions.confluence.googledoc.bean.OAuthTokenPair class : com.appfusions.confluence.googledoc.bean.OAuthTokenPair cause-exception : com.thoughtworks.xstream.converters.reflection.ObjectAccessException required-type : com.appfusions.confluence.googledoc.bean.OAuthTokenPair -------------------------------

Where is a good place to start looking for the cause?

3 answers

1 accepted

This widget could not be displayed.

Hey Cyberhawks, you might be better posting it direct to AppFusions (us) here..

http://www.appfusions.com or info@appfusions.com

Thanks..

Thank you :)

This widget could not be displayed.

Could this have to do with running Java sdk 1.7 on our production server as opposed to running Java sdk 1.6.0_29 on the staging server? I've tried deleting the plugin and re-adding it, deleting it out of cache, verified it wasn't in MySQL PLUGINDATA when it was removed, and restarting the server.

This widget could not be displayed.

Did you recreate your configs on the prod server, including getting a new Consumer key and secret ?

From what you have written, sounds like you just moved it and used the same credentials - and if server is different, then it is not the same.

Support for AppFusions is through our Website forms or info@appfusions.com

Thank you Ellen. I did as a matter of fact create new config files for the new server, but I admit I hadn't thought of that. I only transfered the database and data files.

I installed Java 1.6.0_29 and re-linked it. That fixed a lot of issues with logging, and with Google Docs. It now works fine and so does the logging system. Ryan Goodwin from Atlassian sent me that tidbit that JDK 1.7.0 isn't supported yet (thank you, thank you.)

I'm using Confluence-4.1.6, Centos 5.7, Tomcat 7.0.26, JDK 1.6.0_29, and Confluence Google Docs Connector 1.3.0 among others. With the new release of Gliffy-4.2, everything is running wonderfully. Just FYI for anyone else experiencing these issues with JDK 1.7.0.

Now I get to break it again and see if I can integrate JIRA into this (on the staging server of course.) Muhahahaahah :)

Appreciate you taking the time to post back! Glad you are rolling!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

612 views 8 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you