Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Atlassian Companion plugin issue Edited

Have a problem with Atlassian Companion app for one of the users. App still says "You need to trust the Companion app to edit files" even though Confluence domain has been trusted and linked with Companion.

"Clear all trusted domains" does not help. Confluence still reports the following, while user tries to edit Excel sheet on Confluence page:

Companion.jpg

 

This is working correctly for other users so not sure what the problem might be.

 

4 answers

Hi,

I also have the same issue. I receive the same popup in Chrome. In Firefox, I am able to work with the app.

Reinstalled the app several times, tried Clear all trusted domains and clicking Trust for our domain. The problem persists in Chrome only.

 

Thanks

Maria

Hi Maria,

Another user, Marisa, has commented on this thread with how she was able to resolve the issue. If you haven't seen that, please take a look at those details and see if it helps you.

Shannon

Marisa's answer is not a valid solution to this problem.  I shouldn't need to completely uninstall a product to have it work.  Was there a support ticket open for this?

Mark,

I've had a look and it doesn't appear that Witold ended up raising a ticket for this. Marisa's solution likely worked due to something being saved in the cache or configuration. 

We can have a deeper look for you can submit your Companion App logs to Support. If you're not able to open a support ticket for your own encounter with this issue, please let me know, and I can take care of that for you.

Regards,

Shannon

Hi

I am not sure, if this problem is still open, as it was posted one year ago.

However, I had a similar problem. The "Lets keep things secure" notificarion apeared but not the "trust"-Popup. While investigating the issue, I noticed that the Atlassian Companion task war running multiple times in the task manager. So what helped was shutting down all the Companion Tasks in the task manager, checking if the app was really shut down (by trying to edit a File in Confluence, Confluence should indicate that Companion needs to be installed) and finally restarting Companion. After that I tried again to edit a File in Confluence. That time the trust popup apeared as it should.

What also could help is using another Browser for trusting the domain. Once a domain ist trusted, it works with all browsers. So if you work e.g. with Google Chrome and there is an issue with the popup, try again with Inernet Explorer. If you were able to click "trust" in Internet Explorer, Atlassian Companion will also work in Google Chrome (on the same device of course).

Hope that helps.

0 votes

Hello Witold,

If your user goes and opens Companion App now, they don't have any additional pop-ups asking them to click Trust?

If not, could you have them gather the Companion App logs for you?

  1. Have them replicate the error again, noting the time.
  2. Locate the Atlassian Companion App icon in your Windows toolbar. This is typically at the bottom right of the screen.
  3. Right-click on the icon. Click on the option View Logs.
  4. Have them obtain the log file there, and share it with you.

If you can then have a look at the log files, note the time and the error that followed, and share that with us, then we can determine the issue.

Regards,

Shannon

Shannon,

Thanks for your answer on this. There is a popup asking to trust the app by clicking Trust button but it seems like this is not working. Fortunately we tried this inder internet explorer and it worked. For some reason it does not work under Google Chrome.

Witold,

Once you trust the site in IE, are you able to work out of Chrome, or does it ask you to trust it again?

And to confirm, the URL of the instance isn't changing at all? It's the same instance URL throughout?

I think we may need to raise a support ticket for this, because then we can obtain more information about your instance specifically. If that's alright with you, I can go ahead and raise one in your name and we can reach out to you that way.

Regards,

Shannon

Hi @Shannon Spaniol / @Witold Dziel 

What worked for us was uninstalling everything, clearing the installation directories, then going into Chrome and choose "Restore settings to original default" to ensure there are no popup blockers before reinstalling the plugin. We then managed to get the Trust window on the user's PC. 

Hope it helps! 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

494 views 24 9
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you