Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Anyone also having issues with Atlassian Companion on Catalina 10.15.2? Edited

I updated my MAC to the latest Catalina last night. I use Safari, when I try to edit documents on Confluence via Companion. It says I should install Atlassian Companion yet it has already been installed. I have also given the Companion "Full Disk Access" under security and privacy. Three other users have also reported the issue to me as well. 

4 answers

1 accepted

3 votes
Answer accepted

- Update -

Hello everyone!

I have some updates on this. In January, after my initial response in December 2019, a Blog post about the companion app was released and it had this to tell us:

    Note: Due to a recent security issue the Companion app no longer works on Internet Explorer, Edge or Safari. So this guidance will be for users of Chrome and Firefox.

The full article can be read here:

More information on how to keep using the Companion App can be found here:

I hope this clears the current situation a bit! Let me know all your thoughts.

 

- Old Reply -

 

Hello there, @Khosi Makhene ! Great to have you here collaborating with the community.

As I understand, the installation of our Companion app does not work as expected and is never recognized by Confluence when we use Safari in macOS Catalina. Since Confluence does not recognize the Companion app, editing files from within your own computer does not work.

With this in mind, I recruited the help of a few colleagues and we were able to replicate this behavior. The only workaround we were able to find right now is using another browser. Such as Chrome or Firefox.

Here is the report we raised:

Our best course of action would be to use one of the browsers that work in macOS Catalina and then, vote and watch this report. Voting can help to increase the visibility of the report and watching it will keep you up to date with everything posted there!

Let us hear your thoughts on this, Khosi!

@Diego with all respect but this reply is like a slap on our face. We use Confluence and have hundreds of macos user. In order to simplify mgmt we are only supporting macos std apps. Including safari.

If i understand the Atlassion position correctly you would force us to change our policy and use chrome / firefox because Atlassian is not willing to adress this issue?

Correct?

rgds. Christian

Like Klaus Leiter likes this

We use confluence cloud in our company with mixed client hardware (Windows, Mac OS X, iOS, ) and Browsers (MS edge, MS explorer, Crome, Firefox AND SAFARI) and as a safari-User have the same problem! That is really ugly!

I will hope Atlassian is offering a solution - one month after Christian's request.

Best regards

Klaus

Safari is THE browser on MacOS.  Asking people to switch to using different browser silly.  This is clearly a bug.  Please fix.

Note: When in safari, and a word doc is opened, the popup instructs user to install the companion app to edit.  If companion app is not supported in safari, it should be made clear at this point - don't tell user to install it and find out it does not work and keeps telling user to install after it has been installed.

Like # people like this

Now we have April,15th nothing changed in safari dealing with the Companion App - I do not understand why vote and watch a report on things that do not work. safari is not an exotic browser and the only thing I am interested in is, if Allassian is willing  to fix the bug at all and if when ?????????????????????

Atlassian seems to get as stubborn on macOS issues as Microsoft ...

1 vote
Diego Atlassian Team May 12, 2020

Hello everyone! I am creating a new reply so everyone gets a notification about this.

I have some updates on this. In January, after the creation of this bug in December 2019, a Blog post about the companion app was released and it had this to tell us:

Note: Due to a recent security issue the Companion app no longer works on Internet Explorer, Edge, or Safari. So this guidance will be for users of Chrome and Firefox.

The full article can be read here:

More information on how to keep using the Companion App can be found here:

I hope this clears the current situation a bit! Let me know all your thoughts.

@Diego thank you for sharing.

If i understand the content correctly Atlassian is basically saying "we dont care about the safari users alhtough this is the widest spread browser on macos. Pls use a different one."

In essence you are turning a bug in an Atlassian product into a problem of your mac users.

If I have misinterpreted the essence pls help me get it right.

rgds. Christian

Hi - I'm using Catalina and cannot get the confluence editor to work on Chrome but it does work in Safari. Is anyone seeing a similar issue?

John,

I'm not having that issue, but I can't right-click to get sub-menus on Safari.

Have the same problem. Asked here: https://community.atlassian.com/t5/Confluence-questions/atlassian-companion-mac-doesn-t-work/qaq-p/1361575

 

Atlassian Companion app for mac doesn't work. Instead of suggesting application to edit file with it shows "download companion" window. 

It doesn't work neither for MS office, nor for .PDF files. 

You may see on the screenshot:

  • Companion app is running
  • file type is .PDF
  • Confluence suggest downloading app instead of opening

Versions:

  • MacOS 10.15.4
  • Safari 13.1
  • Confluence server 6.15.1
  • Atlassian Companion app v. 1.0.0
  • Microsoft Word 16.35 
Alex K Atlassian Team May 10, 2020

Hi @Anton Voropaev ,

I have responded to your question on your other post, but I will also copy the answer here for anyone else that may have the same problem. 

Companion for Confluence Server 6.11-7.2 (inclusive) does have some known limitations with certain browsers. However, in your case, I suspect the issue with Mac OS Catalina is a bug that we fixed in the new release of Companion (the symptom of this bug is an error in the log file that looks like "Error: Command failed: sips -s format png"). We released the new version 1.1.0 today and you should receive an automatic update when you start Companion. 

Please let me know if this bug is fixed in the new version. 

Like Anton Voropaev likes this

Thank you for your participation!

Companion still not working unfortunately

Do you like to look into log-files?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

463 views 24 9
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you