It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Anchor Macro Not in Confluence Cloud

I can't seem to find the anchor macro in the new confluence cloud I set up.  I see other macros, but not the anchor one.  Did this get removed in an update?

 

I've also tried the {anchor:name} and that didn't do anything either.

 

Appreciate any insights you've got. It's in a brand new cloud instance we just started up yesterday.  All my previous Confluence was with on-prem. Thanks. 

16 answers

1 accepted

2 votes
Answer accepted

(Edited Nov 2019: this information is no longer accurate, anchors are no longer "temporarily unavailable" they have been removed with no plans to bring back. The open request to bring them back has been closed. The replacement suggested is linkable headings as described in this article. Here is the Confluence Roadmap for additional details.)

 

Hi Nick,

The anchor macro is temporarily unavailable in the new editor. Some people are suggesting that you use the Table of Contents macro as a workaround for now.

However -- if you are also using Jira Service Desk, keep in mind that the Table of Contents macro is broken and not working in the customer portal. Here is the known issue if you want to vote on it: https://jira.atlassian.com/browse/JSDCLOUD-3565

Here are a couple of pages that mention some of the other changes in the new Confluence editor: 

https://community.atlassian.com/t5/Confluence-discussions/Try-out-the-new-editing-experience/m-p/1000813#M3601

https://confluence.atlassian.com/confcloud/confluence-editing-improvements-945107733.html

Hi Sharon,

 

did you know that a link with an anchor does not work when the page is not loader ?

Table of Contents macro as a workaround does not work

Like Rita likes this

The Anchor macro is extremely important to my team documentation. We recently switched over from the server version, and we need this function or a reliable substitute. I have tried the ToC as a workaround and it is not adequate.  

Come on! Bring back anchors!

Is there a way to switch to an old editor in cloud? 

This would be very helpful. Cannot believe this functionality is just.. gone.

It feels weird to find out that this feature seems to be abandoned without any further official statement. The lack of reaction from offical side puzzles me. Step up, Atlassian!

We just moved to Confluence Cloud for evaluation. We intent to change systems. Our prior solution lacked anchors. I consider them essential and a minimum requirement to work with structured text.

Not having them and not even having an official statement if/when they will be provided again leaves us with high uncertainty.

This is nothing short of a disgrace. No response to users requests is confirming cost cutting efforts https://www.smh.com.au/business/companies/atlassian-unveils-premium-software-tiers-as-it-looks-to-boost-revenue-20190906-p52omu.html

Same issue, while use of anchors is so important.
I found that anchors are available in the home page of a new space in confluence cloud.

Not in a new created blanc subpage.

Work-around seems to be: iso creating a new page, copy the homepage of the space and start working from there.

Note: if another user finds more handy work-arounds, please let me know.

To Atlassian - I'm a consultant working in several companies, sometimes bringing in Atlassiant tools. All of my customers need these anchors... please bring them back. Or provide us users with the reasons why they do not come back. It has impact on strategies I am suggesting to customers.

I looked Into Editor Roadmap and it says that anchors have been replaced by linkable headings: https://confluence.atlassian.com/confcloud/confluence-editing-improvements-945107733.html#ConfluenceEditingImprovements-Linkableheadings. 

 

Tried the headings and so far experience is miserable: 

- you have to go back and forth from publishing to editing page to generate heading link and paste it!

- once pasted inside the same page, link displays the page name and not the heading's name! Come on, guys, have you ever used MS Word or any other word processor before rolling out this feature?

Looks like Atlassian does not care about basic UX consistency any more.  Taking into account the subscription price increase, changing the platform is really worth consideration...

Hi Sharon,

is there an idea when the macro will work again?
I did not found a ticket to it topic in JSDCLOUD.

regards,
--Kai

Sharon_Helms Community Leader Mar 22, 2019

Hi Kai,

I haven't seen a date for when the macro will work again, but it is listed as "soon" on the Confluence Cloud Editor Roadmap, found here:

https://confluence.atlassian.com/confcloud/confluence-cloud-editor-roadmap-967314556.html

 

Best wishes,
Sharon

Like KSH likes this

April 30th, anchor macro is still not working.

May 28th, anchor macro still doesn't work. Confluence is very stable

Like # people like this

June 3, no anchor macro :(

Like Hamza_Qaisrani likes this

June 17, no anchor macro. This is an important feature for longer documents so it'll be very useful once available again!

Like # people like this

June 26th - still broken.

Like # people like this

Now July. It's not as if it's standard sort of behaviour for a wiki...

Like # people like this

still no anchor makro!

This is very frustrating. Why does this take so long?

In the cloud documentation it is mentioned everywhere: https://confluence.atlassian.com/confcloud/insert-links-and-anchors-724764900.html

Atlassian, you should at least be honest and update these documents!

Like # people like this

Interesting note: they have a page describing their new editing experience, and at the end of that page there's a highlighted paragraph mentioning that anchors are still "temporarily" not available, with some detail on a couple workarounds. I guess the whole anchoring thing is proving difficult for them....

Like # people like this

And the suggested 'workarounds' are a little old-fashioned, considering it's 2019 and this is the newest version.

Like Zachary Wallace likes this

It's August 2019. Still no working anchor macro. This is really frustrating... Cmon' Atlassian...

Like # people like this

For the next 30 seconds I am going to throw a tantrum!

Then I will resume my adult like facade

 

"I need the anchor macro - I had it when working on a server version - I am finding it very hard to get the functionality I need without it

How long before it is available - I really don't want workarounds

I need it now!

Like # people like this

When will you guys at Atlassian get off your you know what and get this feature working?

Seriously, the first post was back in February 26 and it's August.  That's almost 6 months. 

I might as well go back to Word and SharePoint...

Anytime today people!

Like Market Matters likes this

Atlassian team, is there an update on this please?

Like # people like this

+1 - Anchors are very important in our workflow. 

Like # people like this

September 3rd and still no anchors :'(

Like # people like this

September 27th chiming in.. still adrift at sea.. anchorless. 

Like Peter_White likes this

When marketing rules the communication..

don't you know: "soon" is a synonym for "never" nowadays

communicating the truth seems to be a decision of using the alternative truth or the alternative one.

They may fear negative consequences in communicating the real situation, so it's our task to make consequences... but wait a minute.. we can't.. they are effectifly a monopolist

Nov 14, still no anchor. :(

Oh for crying out loud, can I haz Anchor for christmass at least, *please*?

Like Per_Schrader likes this

April 22, 2020, still no anchors.  Anchors are "THE" feature of long format pages.  I cannot believe Atlassian ever moved from a product that "had" them, to one that did "not".  Unforgivable.  Looking for alternatives to Atlassian now, e.g. for a real product.    I do not understand a "no plan" for this feature.   How do people link inside their pages?  Using the header text link feature breaks if the text changes, which is just not workable for actively maintained documents.   Bring back the anchor, bring back the anchor. bring back the anchor....   INFINITY.  BRING BACK THE ANCHOR.   Just WOW!  Cannot believe a product without this cross link functionality.   Not tolerable.

Like # people like this

Well said David!! x10000 here.

This just bit us in the backside as well.  Until the "upgrade" to the latest version of the Confluence editor, we had a functioning glossary with self-referential links. 

A few months ago (when Atlassian began rolling out their new editor), I noticed that every so often all of the internal links would mysteriously break and I would have to recreate them. Now that our entire org has been migrated to the new editor, the situation is clear:  Anytime the new version of the editor opened that document all references to anchors would break.  Opening the document with the old version of the editor allowed me to restore the links to the anchors. 

Now the only way to fix it would be to rewrite the entire document to use headers for every definition term. Completely unacceptable.

Almost november and still no anchors.

Below is a link to the Backlog for this in JIRA.  It shows deployed but the JIRA is closed and Anchors still don't appear to be working in Cloud Editor.....

CONFCLOUD-66773

Craig, thanks for that link, that's really helpful!

If I'm interpreting the dialog in the comments correctly, it's saying that anchors are NOT coming back, and the 'linkable headers' feature has instead been released as a replacement for them. If that's the case then it explains why the item is closed but we still don't see anchors as a feature.

There's then a comment enumerating some of the shortcomings of linkable headers, and it does sound rather limited.

So, if I'm reading that right, we're never getting anchors back, and have to use linkable headers instead. I hope I'm wrong...  :(

Frustrating anchors are not available still. As a team, we have only just started to use Confluence and it's been a really positive experience so far. But no anchors takes away a massive feature. 

My workaround is to export the confluence page to word and then reimport it. The import anchors any headings.

The main drawback to this is you may not get certain content back, such as images.

 

Dec 02: Bring anchors back!

Hi,

Having read through these comments a while ago, while looking for "anchors", I completely missed the fact that they've been replaced by linkable headers (I only found out recently via another source).

For our use case, linkable headers work fine. Perhaps we're in the minority, but for us...

1. Going between publish and edit to insert the linkable headers is not ideal, but who cares? Work around it - just have 2 browsers open, or 2 tabs. If you really need the anchors, it works.

2. You can edit the linkable headers to give them whatever name/value you want once they are created. So just leave creating the anchors till the end of the page create or edit. Sure it'd be handy to do it inline, but it's not such a hardship.

3. If my team were creating content so large or complicated in a wiki article that it absolutely required anchors to navigate, I'd say we needed to create a document, or anything else, apart from a wiki article (or start simplifying the article). We have other storage for "proper" documentation - or other content. That's just not the type of thing we like to use our wiki for.

Maybe some people use a wiki as a doc store, or import lots of documents with TOCs, Headings, Anchors etc, for some reason, so I guess in that case, it's probably a pain.

For us, anchors just aren't really all that critical for the way we want to write, create and edit our Confluence wiki articles, so "linkable headers" kind of works well enough. Just my 2c.

Hi Glen,

I had seen a mention of linkable headers back in October 30th and mentioned it here. (though it's a bit buried in a reply to another comment).

I think the bottom line is that the anchor macro was a more flexible, easier to use option, and linkable headers are more restricted and have an awkward work flow. Taking away functionality and replacing it with something less capable is never a good thing to do.  

Happy to hear that you found the new solution acceptable but, yeah, you're definitely in the minority here! (And, given it's a place to complain about features more than just come to praise them that's not a surprise....)

Like Carla Woodgate likes this

He Edward,

Yes! The Anchor macro is more user-freindly as well as efficient. To have to toggle between view and edit just to provide "jump-to" functionality is frustrating. 

Sorry Glen, you are definitely in a minority, but if it works...it works. I have my team doing it with Linkable Headings, but they are grumbling a lot about it. 

Like Alexandr_Reznic likes this

When a feature in a tool is removed or replaced and it breaks existing documents, that provides a strong incentive to replace the tool. Especially when customers were not warned about the breaking change ahead of time.

Well, major drawback for me, when installing quality management systems using this technology is not being able to use hyperlinks from e.g. gliffy diagram sections to anchors in other location of the pages... anyone else bothered by this?

22 November and Panel Macro are still missing, so TOC (Table of Contents) cannot have title, border, background color. In that way is useless #TOC because is not visible to users!
Please vote here to make our voice heard:

https://jira.atlassian.com/browse/CONFCLOUD-67825

Sadly the linked headline replacement functionality does not work for headlines within a table. No Icon to copy&paste the link from appears in tables (as far as I can see).

Does anybody have another workaround for headlines in tables?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What project did you transition or start on Confluence with the shift to remote work?

It’s been great to hear from fellow users over the last few weeks about the best tips and fun moments you’ve had working on Confluence since the transition to working remote. I’d love to keep the c...

157 views 3 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you