Anchor Link to another Page won't work consistently

I'm using Confluence 5.8.8.   I am not using the TOC macro.  I am using the anchor macros.  My problem is they're all created the same way, but some work and some don't.  Some don't go to the anchor, just to the top of the page.   I've removed and replaced the text and anchors with the same result.  Is there a way to fix this?

2 answers

Capitalization is strictly enforced. You can drop spaces (e.g. anchor name = anchorname), but the capitalization must be exact (e.g. Anchor name ≠ anchor name).

Unfortunately, if you use the wrong capitalization, the link will still be blue because the page name is true, even if the anchor doesn't exist (or Confluence thinks it doesn't exist because of mis-capitalization).

I actually discovered the answer to this, but haven't seen it documented anywhere.  When the anchor is on a page that opens with no scrollbar or the scrollbar hits the bottom and the anchor is in view, the link just goes to the page.   

That sounds like the correct standard behaviour. What would you expect to happen instead when the anchor is already in view and there is no more space to scroll down?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

1,208 views 2 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you