71% - An unexpected error occurred during step: Migrating users and groups. Error: We couldn't migrate your users because you will exceed your user limit for Confluence Cloud. Upgrade your cloud plan and try again.
I'm trying to migrate into my existing server license (50 user) and have about 150 current users, 100 of which are disabled. When I did a test migration, all of the users migrated along with the spaces I selected. I then ensured that the disabled users were disabled in cloud. No problems. But when I tried the exact same thing on my existing server license cloud trial, I got the error above. (The percentage is useless and has nothing to do with the number of users migrated.) Since I have no way to select which users are migrated, I had to try deleting users from my current server version. This means I now have anonymous references in data going back 8 or more years.
Why does trial migration on an existing license work differently than a regular trial one?