Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,300,857
Community Members
 
Community Events
165
Community Groups

All my space in space director is pointing to localhost

I have hosted my confluence page from old backup file in server and I can able to access through ip but with in my space directory all my space URLs are pointing to localhost not to the ip but if I copy this url and change the local host to my ip it is working So I think there is some routing issue in tha space directory page how can I make all space to point to URLs starting with my ip

1 answer

1 accepted

1 vote
Answer accepted

Welcome to the Atlassian Community!

Take a close look at the actual links on the page - when you hove the cursor over one, does the browser give you a small help-text with the "localhost" url in it, or is it actually pointing somewhere else?

We need to know that to be able to rule in or out your network settings.

In fact, my best guess is that when you're talking about "ip", you mean "the ip of the server I put Confluence on", and your old system was literally running on "localhost" (meaning "this machine).  So the base url is set to "localhost", so the links fail when you click on them because that means "the machine the browser is running on".

But check what the urls are first

As you mentioned when I place the cursor on the space name in space directory it shows like localhost:8090/... But and when I click it it shows page not found but If I just change the localhost as my server ip in browser and open it the space page is visible 

I thought so.

"localhost" always means "this machine", so when you're using your browser to click on a link with "localhost" as the host, you're trying to access the same machine the browser is running on, not the server.

The reason it's giving you localhost links is that the base url which it bases all its links on is set incorrectly.

Go to the server via the ip address and log in as an admin (if it gives you "page not found", replace the localhost in the url with the ip address and load it again).  Go to Admin -> General settings and correct the base url.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

388 views 2 13
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you