8443 port added after redirect from http Edited

Hello all!

I use this solution https://confluence.atlassian.com/doc/running-confluence-over-ssl-or-https-161203.html for HTTP redirect to HTTPS. Now, if use http:// confluence redirecting to https, but added :8443 in end adress. How remove this?

If use https://  then isnt display port to end.

 

Step 5. Add a Security Constraint to Redirect All URLs to HTTPS

<security-constraint>
  <web-resource-collection>
    <web-resource-name>Restricted URLs</web-resource-name>
    <url-pattern>/</url-pattern>
  </web-resource-collection>
  <user-data-constraint>
    <transport-guarantee>CONFIDENTIAL</transport-guarantee>
  </user-data-constraint>
</security-constraint>

 

1 answer

0 vote
Daniel Eads Community Champion Apr 14, 2017

Hi Viktar,

:8443 is being displayed because that's the port that Tomcat is serving Confluence over. There are security concerns with Tomcat serving over the standard port 443 for HTTPS, so you should consider using a reverse proxy intstead.

As a rule of thumb, it's easier to manage SSL certificates through a reverse proxy such as nginx or Apache than directly through Tomcat. You'll also get some side benefits by using a reverse proxy such as better connection handling, gzip compression, and the ability to make use of http/2.

Check out this Atlassian article on setting up nginx with HTTPS in front of Confluence: https://confluence.atlassian.com/confeap/running-c onfluence-behind-nginx-with-ssl-849150880.html

I've also written some more detailed instructions on getting nginx set up if you're using CentOS/Ubuntu: https://danieleads.com/turbo-charging-your-conflue nce-with-nginx/ - small caveat that my article doesn't contain the extra lines in your configuration that you need to get collaborative editing working in Confluence 6.0 - but this only affects Confluence 6.0 and not any versions before/after 6.0.

Hi!

 

No no! We need only redirect for HTTP to HTTPS, without proxy and  difficult  settings

Modify the redirectPort in /conf/server.xml from:

<Connector port="80" connectionTimeout="20000" redirectPort="8443"
                maxThreads="48" minSpareThreads="10"
                enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8"
                protocol="org.apache.coyote.http11.Http11NioProtocol" />

to:

<Connector port="80" connectionTimeout="20000" redirectPort="443"
                maxThreads="48" minSpareThreads="10"
                enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8"
                protocol="org.apache.coyote.http11.Http11NioProtocol" />

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

365 views 20 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you