Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

confluence upgradation from 6.2 to latest version

Hi team,
we are planning to upgrade confluence 6.2 to latest version, need your assistance on this.

1 comment

"Need assistance" is very broad.  What help are you looking for?

Like Srikanth Reddy K likes this

I'm looking for step by step procedure to upgrade confluence 6.2 to latest available version,

before that i would like to test in a staging environment!
please let me know from where i need to start

Start with https://confluence.atlassian.com/doc/upgrading-confluence-4578.html

Clone your production down to staging and run through the documented upgrade procedure from those docs.

Like Srikanth Reddy K likes this

Hi Nic,
1)launched a new instance from existing confluence AMI , so  home directory remains same.

2) created a new database and restored data from  prod database also updated the database in server.xml

after starting the tomcat im getting few warnings but tomcat shows as running,
still not able to access it from UI

tomcat logs:
24-Feb-2021 19:03:36.021 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server} Setting property 'debug' to '0' did not find a matching property.
24-Feb-2021 19:03:36.104 WARNING [main] org.apache.catalina.startup.SetAllPropertiesRule.begin [SetAllPropertiesRule]{Server/Service/Connector} Setting property 'debug' to '0' did not find a matching property.
24-Feb-2021 19:03:36.128 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server/Service/Engine} Setting property 'debug' to '0' did not find a matching property.
24-Feb-2021 19:03:36.135 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'debug' to '0' did not find a matching property.
24-Feb-2021 19:03:36.186 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'debug' to '0' did not find a matching property.
24-Feb-2021 19:03:36.627 INFO [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["http-nio-8080"]
24-Feb-2021 19:03:36.655 INFO [main] org.apache.tomcat.util.net.NioSelectorPool.getSharedSelector Using a shared selector for servlet write/read
24-Feb-2021 19:03:36.662 INFO [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["ajp-nio-8009"]
24-Feb-2021 19:03:36.664 INFO [main] org.apache.tomcat.util.net.NioSelectorPool.getSharedSelector Using a shared selector for servlet write/read
24-Feb-2021 19:03:36.665 INFO [main] org.apache.catalina.startup.Catalina.load Initialization processed in 740 ms
24-Feb-2021 19:03:36.678 INFO [main] org.apache.catalina.core.StandardService.startInternal Starting service Tomcat-Standalone
24-Feb-2021 19:03:36.679 INFO [main] org.apache.catalina.core.StandardEngine.startInternal Starting Servlet Engine: Apache Tomcat/8.0.39
2021-02-24 19:03:39,463 INFO [localhost-startStop-1] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 6.0.5 [build 7103 based on commit hash 9740d52e06037c926d0bef8c46735f0805791491]

followed this link

https://confluence.atlassian.com/doc/create-a-staging-environment-for-upgrading-confluence-866094180.html

done with step 1,2 and 3
Replicate database and confluence as same as production, after starting tomcat 

getting page not found error

please do the needfull

logs looks like as same above comment

NOTE : Confluence Version was 6.0.5

hey guys I'm able to clone successfully the setup into staging 
since it is 6.0.5 version, i don't find a proper documentation on community


 https://confluence.atlassian.com/doc/upgrading-confluence-4578.html

i have referred the link which you have provided, i don't think so it is suitable method for my version, because i don't see few options in my confluence
eg:  General Configuration > Plan your upgrade
       General Configuration > Troubleshooting and support tools

What do your logs say the upgrade errors are?

could you please let me know how can i upgrade  6.0.5 version to latest one

Follow the upgrade doc I gave a link to.  I'm sorry, I can't tell you much more than that.  You have not told us where you are stuck (or where you have, we've told you how to proceed), so all we can really say is "do the upgrade as per docs"

IM Having active license but still getting below error
License Inconsistency: Confluence support and upgrades for your current license have expired.

You may own a valid licence, but this message means that the one in Confluence has ended.  Check your Atlassian account and apply your "active licence" to your Confluence (should be a copy and paste" action)

Comment

Log in or Sign up to comment
TAGS
Community showcase
Published in Confluence

Confluence Mythbusters: Does Atlassian even use Confluence?

Hi, Confluence collaborators! As part of #Confluence-Collaboratory month, we’ve created a very special Mythsbusters segment, where we're dive into an interesting myth and uncover the truth behind i...

1,390 views 7 29
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you