Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,359,865
Community Members
 
Community Events
168
Community Groups

Problems with label macros across spaces

Edited

We use both the Content by Label Macro and the Page Properties Macro to display content across multiple spaces for specific Labels.

These were working correctly but they are now no longer displaying content from any space but the one the macro is used in even is spaces are specified explicitly in the macro.

Atlassian team this appears to be a recent bug introduced as the same problem was raised here recently Is anyone else experiencing issues with the Content By Label macro? 

 

UPDATE

Atlassian Support has indicated that these issues are covered under the following known bugs with the status of AWAITING RELEASE:

6 comments

I am encountering this issues as well!!

Like # people like this

Same issue as well. 

Like # people like this
Tessa Espena Atlassian Team Jul 21, 2020

Encountered the same too

Like Bridget Maloney likes this

Thank you so much for the update, @Brett Henderson !  I'll check out the linked issues and watch them too!

Edit - I spoke too soon, they are private - but thank you again for reaching out to Atlassian via support, Brett!

Like Brett Henderson likes this

I'd also found that and have raised that with Atlassian. They will hopefully be public over night my time (Australia) as the owners are in the US.

Like # people like this

I've heard they are both internal bugs, and hence not publicly accessible.

Atlassian Support has indicated the bugs should now be resolved, and in my cloud instance that appears to be the case.

Like Bridget Maloney likes this

Whoo hoo!  I am seeing the same thing - thanks again, @Brett Henderson ! 

Deleted user Sep 30, 2020

Hi, all. I came here today because it looks like the monkeys were at it with their wrenches again. . . this macro is no longer dynamically updating. 

I created the page that the macro is on and the labels for it a couple of weeks ago, if that helps. In other words, it was a fresh page with fresh instances of the content by label macro). It is not dynamically updating. Not even when the page is reloaded, all my browser cache is cleared out. What I have to do it go into each instance of the macro, edit it (changing nothing), save it again, and re-publish the page. This is ridiculous. If I need to manually go in and make it keep track of the labels, I could just update the list of pages myself and not use the macro at all. The whole point was the automate the lists.

Can I get confirmation from anyone else?

Comment

Log in or Sign up to comment
TAGS
Community showcase
Published in Confluence

Watch 4 Confluence apps compete for Best App Demo in September's Appy Hours

Calling all collaborators! Appy Hours on the Atlassian Community is a monthly event where 4 Partner and app vendor presenters go head-to-head with 5-minute demos for the title of Best App Demo. I...

492 views 0 12
Read article

Atlassian Community Events