Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,202
Community Members
 
Community Events
176
Community Groups

Install successfully,but no way to connect

 

your browser.
Confluence 7.0.1 can be accessed at http://localhost:8090
Finishing installation ...


[root@VM_0_16_centos qiuxin]# curl http://localhost:8090
curl: (7) Failed connect to localhost:8090; Connection refused

1 comment

[root@VM_0_16_centos qiuxin]# netstat -an |grep 8090
[root@VM_0_16_centos qiuxin]# ps -ef|grep conflu

The confluence is not well run ?

That probably does mean it is not running.  I usually look for "java" though, in case you have not used "confluence" in the path name.

Go to the <install>/bin directory and try running ./start-confluence.sh - that should start it, or give you an error to work with

Hi Nic,

Thanks for your response.

Why do we need to look for "java"?  Bin Installation does not require Java installation, right?   Jave does NOT exist in my virtual machine.

[root@VM_0_16_centos ~]# ps -ef|grep java
root 11973 11835 0 17:03 pts/0 00:00:00 grep --color=auto java
[root@VM_0_16_centos ~]#

Best,

Robert 

In term of the install path, I completely use the default setting in the process of installation.    The details are itemized below:

Select the folder where you would like Confluence 7.0.1 to be installed,
then click Next.
Where should Confluence 7.0.1 be installed?
[/opt/atlassian/confluence]


Default location for Confluence data
[/var/atlassian/application-data/confluence]

[root@VM_0_16_centos bin]# pwd
/opt/atlassian/confluence/bin

[root@VM_0_16_centos bin]# ./start-confluence.sh

To run Confluence in the foreground, start the server with start-confluence.sh -fg
executing using dedicated user: confluence
If you encounter issues starting up Confluence, please see the Installation guide at http://confluence.atlassian.com/display/DOC/Confluence+Installation+Guide

Server startup logs are located in /opt/atlassian/confluence/logs/catalina.out
---------------------------------------------------------------------------
Using Java: /opt/atlassian/confluence/jre//bin/java
2019-09-23 17:33:49,296 INFO [main] [atlassian.confluence.bootstrap.SynchronyProxyWatchdog] A Context element for ${confluence.context.path}/synchrony-proxy is found in /opt/atlassian/confluence/conf/server.xml. No further action is required
---------------------------------------------------------------------------
Using CATALINA_BASE: /opt/atlassian/confluence
Using CATALINA_HOME: /opt/atlassian/confluence
Using CATALINA_TMPDIR: /opt/atlassian/confluence/temp
Using JRE_HOME: /opt/atlassian/confluence/jre/
Using CLASSPATH: /opt/atlassian/confluence/bin/bootstrap.jar:/opt/atlassian/confluence/bin/tomcat-juli.jar
Using CATALINA_PID: /opt/atlassian/confluence/work/catalina.pid
Existing PID file found during start.
Removing/clearing stale PID file.
Tomcat started.
[root@VM_0_16_centos bin]#

[root@VM_0_16_centos bin]# cat /opt/atlassian/confluence/logs/catalina.out
OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x00000000c0000000, 1073741824, 0) failed; error='Cannot allocate memory' (errno=12)
#
# There is insufficient memory for the Java Runtime Environment to continue.
# Native memory allocation (mmap) failed to map 1073741824 bytes for committing reserved memory.
# An error report file with more information is saved as:
# /tmp/hs_err_pid5650.log
OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x00000000c0000000, 1073741824, 0) failed; error='Cannot allocate memory' (errno=12)
#
# There is insufficient memory for the Java Runtime Environment to continue.
# Native memory allocation (mmap) failed to map 1073741824 bytes for committing reserved memory.
# An error report file with more information is saved as:
# /tmp/hs_err_pid6063.log
[root@VM_0_16_centos bin]#

Finally got the result from the log,  the memory of virtual machine is NOT enough.  

Ah good, yes, you need to run this on a machine which has enough memory to hold the operating system plus the maximum heap size you set for both confluence and synchrony (if you want the collaborative editing)

Comment

Log in or Sign up to comment
TAGS

Atlassian Community Events