Insert Gliffy or Draw.io or Lucidchart diagram not working

I am currently unable to add any kind of diagram to existing pages. This has occurred to 2 users on different pages. I click on the insert +, then select any of the draw tools. I briefly see a window appear, then it goes away.  Insert Link does work, so perhaps it's external add-ins that have a problem.

Running Chrome 57.0.2987.133 (64-bit) on Linux. I have disabled intrusive browser plugins like uBlock Origin for Confluence. Also confirmed not working in IE 11, Firefox 53, Opera 45 & Edge.

I see this error in Chrome console when trying to insert a drawing : Uncaught ReferenceError: connectHost is not defined

Full message log from insert:

d1ixbz5qgnvms3.cloudfront.net/satovicinity.atlassian.net/wiki/s/.../_/download/contextbatch/js/_super/batch.js?locale=en-GB:111 AJS's create element functionality has been deprecated since 5.9.0.
No alternative will be provided.
Use document.createElement() or jQuery.parseHTML(), or preferably use a templating library.
d1ixbz5qgnvms3.cloudfront.net/satovicinity.atlassian.net/wiki/s/.../_/download/contextbatch/js/_super/batch.js?locale=en-GB:111 AJS's create element functionality has been deprecated since 5.9.0.
No alternative will be provided.
Use document.createElement() or jQuery.parseHTML(), or preferably use a templating library.
com.atlassian.plugins.atlassian-connect-plugin:confluence-macro-v5.js?acjsFiveVersionEnabled=true:5 Uncaught ReferenceError: connectHost is not defined
at Object.openCustomEditor (com.atlassian.plugins.atlassian-connect-plugin:confluence-macro-v5.js?acjsFiveVersionEnabled=true:5)
at Object.opener (d1ixbz5qgnvms3.cloudfront.net/satovicinity.atlassian.net/wiki/s/…connect-plugin:macro-editor-resources-v5.js?acjsFiveVersionEnabled=true:20)
at Object.loadMacroInBrowser (d1ixbz5qgnvms3.cloudfront.net/satovicinity.atlassian.net/wiki/s/…uence.plugins.confluence-macro-browser:macro-browser-js.js?locale=en-GB:76)
at Object.successCallback [as success] (d1ixbz5qgnvms3.cloudfront.net/satovicinity.atlassian.net/wiki/s/…ence.plugins.confluence-macro-browser:macro-browser-js.js?locale=en-GB:124)
at d (d2uowa935fr33t.cloudfront.net/download/modules/jquery/1.7.2.1-confluence-custom-m04/jquery-min.js:1)
at Object.fireWith [as resolveWith] (d2uowa935fr33t.cloudfront.net/download/modules/jquery/1.7.2.1-confluence-custom-m04/jquery-min.js:1)
at r (d2uowa935fr33t.cloudfront.net/download/modules/jquery/1.7.2.1-confluence-custom-m04/jquery-min.js:3)
at XMLHttpRequest.r (d2uowa935fr33t.cloudfront.net/download/modules/jquery/1.7.2.1-confluence-custom-m04/jquery-min.js:3)

1 comment

I heard another report of this. Submit it to Atlassian support, it needs a reboot, or whatever it is they do. Please also report back what it is they do to save future readers some time.

Did you get anywhere with support?

It took several days for the process to start & I'm still trying to get a resolution to this problem. It is stranger than I originally thought - sometimes I can create a diagram, and then 5 minutes later it doesn't work. Seems very flaky for us at the moment.

It has been verified by the support team as a bug CONFCLOUD-55668

Thanks for letting us know. Wow, low prority...

Comment

Log in or Register to comment