It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Help needed for IIS Reserve Proxy with Confluence Edited

Hello all,

Firstly thanks for taking your time to read and assist me in my issues.

I purchased and installed Confluence on the same server hosting my website via IIS. I've read the IIS Proxy guide for Confluence which can be found in my link below. However, things are still not working properly and I have a few questions about the setup.

I'm attempting a www.domain.com/confluence format for my setup.

Below are the steps I took and my questions:

Part A

1. Stopped Confluence

2, Added context path "/msl" as the extension I wanted to use in "path="
Question: is <> required in the /msl section? Ive tried it both ways and it makes no difference.

<Context path="/msl" docBase="${catalina.home}/atlassian-<atlassianapp>" reloadable="false" useHttpOnly="true">


3. Skipped step 3 as it was for fisheye and crucible only it appears.

3.2 Added scheme, proxyname and proxyport attributes inside the connector directive.
Question: From my understanding subdomain is not required in the proxyname if context path is being used correct? Also if I wanted to force HTTPS can I do that here by making proxyport 443 instead of 80 and moving scheme to https? If I'm self hosted but using an SSL cert on my existing site. Do I even need to change the below to 443 if everything is already redirected to 443 via Wordpress on my site?
My Connect is as follows:

<Connector port="8090" connectionTimeout="20000" redirectPort="8443"
maxThreads="48" minSpareThreads="10"
enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8"
protocol="org.apache.coyote.http11.Http11NioProtocol"
proxyName="mydomain.net"
proxyPort="80"
scheme="http"/>

 

Part B

1. Installed request Routing and URL rewrite in ISS

2. Enabled Proxying on ARR.

3. Added Application pool to IIS

4. Added rewrite rule to IIS site

Question: When adding pattern (.*) to my site. It denies access to my root site. Once remove the site comes back online. Should this pattern be matching the link I want externally for Confluence? i.e https://mydomain.net/msl ?

Expression used is "http://<JIRA_url:Port>/{R:1}" should this expression be the link I want Confluence to show up on? or just my root domain? if im using SSL should I force this to https? so should the expression state http://mydomain.net/{R:1} or http://mydomain.net/msl/{R:1}.

I believe this section is where the root of my issues reside.

5. Enabled Tune Request Filtering and enabled Allow Double Escaping

6. Disable Output Caching

7. Enabled long URLs via registry key edits.

 

Rebooted IIS. Restarted Confluence services. Now I am unable to access my website unless I disable the url rewrite rule.

Any assistance is greatly appreciated!

Links:
https://confluence.atlassian.com/kb/proxying-atlassian-server-applications-with-microsoft-internet-information-services-iis-833931378.html

https://confluence.atlassian.com/doc/configuring-the-server-base-url-148592.html

https://community.atlassian.com/t5/Confluence-questions/IIS-reverse-proxy-with-Confluence/qaq-p/908186

 

 

 

0 comments

Comment

Log in or Sign up to comment
TAGS
Community showcase
Posted in Confluence

What project did you transition or start on Confluence with the shift to remote work?

It’s been great to hear from fellow users over the last few weeks about the best tips and fun moments you’ve had working on Confluence since the transition to working remote. I’d love to keep the c...

32 views 2 4
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you