It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence Forgot How to Count

So. This is a bug I encountered yesterday, and today I was able to fix it without completely rebuilding the page but I have no idea how. Magic. It drove me nuts yesterday. So I'm hoping someone recognizes this bug and can tell me what happened, or at least a fix that's not as magically confusing, 'cause I have a few more tables that are doing this. 

I have a pretty sizable document (~100 Microsoft Office Pages) with tables littered throughout the document. We have a "Step - Action - Result" standard, and so I use the insert numbering column function.

insert.png

We commonly have collapsed Code Blocks in the Result Section of our Documents, which has never been an issue. In edit mode, this particular table looks fine:edit.jpg
In view mode however... Step 1 disappeared.

no1.jpg

 

At first I thought the first row just disappeared... and then I found it.

12-1.jpg

 

I'm pretty sure 1 is NOT the number that follows 12. So to try to troubleshoot it, I copy and pasted the table into my personal space and it got worse!

bug.jpg

 

I returned the code back into the code blocks (all 12) and it fixed itself. No idea how or why that worked, so I copy and pasted it back into the document, and it stayed fixed. So I know it's not a bug with the page.

Oh, but when I pasted back into the original document insert numbering column was no longer checked (I'm assuming because when I pasted it, it thought that all the columns were manually built).

done.jpg

 

However, we have some tables that have 100+ rows and recreating / whatever I just did would be ridiculous to bother with. Luckily, all the buggy tables have been short.

I have not seen this problem in tables that do NOT have the numbering column, but I also am not quite sure if the order of those tables actually matter (or that I would notice anyway).

There's no hidden CSS or HTML or anything anywhere that I can find that would cause this.

1 comment

Davin_Studer Community Leader Mar 30, 2018

Do you have the source editor add-on? If you are finding something wonky happening my first thought would be to go look at the source and see if there is something wonky with the source.

I apologize, I should have clarified... when I said there's no hidden HTML or anything that's what I meant. 

Davin_Studer Community Leader Apr 05, 2018

I've tried to replicate your issue on my end and I can't seem to get the same behaviour. If there is nothing amiss with the html then I'm not sure what the issue could be. Sorry.

Comment

Log in or Sign up to comment
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

306 views 9 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you