Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

Recognition

  • Give kudos
  • My kudos

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Space will not migrate or export/import

I've migrated all of our Confluence spaces from on prem to the cloud, except for one. I used the Cloud Migration Tool and every time I try to migrate just that site it fails with the same useless error: "Failed to export [spaceKey=EXD,fileid=7ea....,cloudId=4e60....]" (I used the ... instead of typing out the full ID).

The only errors I see on the server have to do with failing to find images (that don't exist) or this: "[swift.confluence.scriptutil.ScriptUtils] isReadOnly Cannot determine whether readonly mode is enabled : {}"

I've tried exporting/importing and get an error about the version of Confluence Server needing to be newer but that doesn't apply since my version of server is newer than the minimum listed in the error. 

I assume there is something wonky in this space but can't pin down what it is.

Any ideas?

4 answers

0 votes

Hi @Abby Cooke , 

Suspect the spaceName or SpaceKEY already exist in the Confluence Cloud.

Can you verify the spaceName and key in Confluence Cloud. Duplicate spaceName and key will not allow the import of the space?

Also, Could you confirm with us from what version of Confluence the space export originated?

Thanks,

Kiran.

Another suggestion or two if @Kiran Panduga _Appfire_ 's don't work out:

Have you tried exporting the space without using the tool? Space Settings-Content Tools-Export-XML.

Also, have you verified that there are no permission restrictions on the space to not allow it to be exported?

Darryl

The space doesn't exist already - neither the name nor the key. 

I tried the export and it keeps failing with the error about how it needs to be 6.14 or later, but I'm on 6.7.1.

The permissions are the same on both sides.

Like I said, it works for all other spaces. For this one it absolutely will not. On trying to export it does fail unless I exclude a certain page but I see nothing strange about that page. I tried removing it and the images on it, then it exported but the same error came up on import. 

 

Thanks for your responses. I'm baffled.

@Abby Cooke I assume you're using either Standard or Premium, both of which entitle you to support directly from Atlassian. You may want to contact them if you have exhausted searching the Knowledgebase and Community forums.

Atlassian Support

 

Darryl

I have a case open with them. I was hoping while I waited to find someone else who encountered this. I've tried everything I can think of. 

Like Darryl St_ Pierre likes this

Did your other spaces utilize the Swift Scripting add-on?  I know that it is not supported by Cloud, so that could be causing your issues.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence Cloud

Share your Confluence Cloud experience for a chance to win $500!

Take our 5-minute survey to win a $500 Visa gift card! Are you currently using Confluence Cloud? We want to hear from you! Fill out this quick survey about your Confluence Cloud experience so we ...

255 views 5 13
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you