Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,366,304
Community Members
 
Community Events
168
Community Groups

New editor is now the default and it's broken!

Edited

I don't think I have even been more annoyed with Atlassian because a fundamental capability seems no longer possible, That is copy and pasting content from an old editor page to a page created with the new editor.

I am simply trying to copy a Panel, which contains a section, with two columns, and a few pasted in icons. A nice looking page, created with care.

It should be a straight forward copy and past, from one page to another, like I've done in all the years I've worked with Confluence.

ATLASSIAN, WHAT WERE YOU THINKING?

Even more strange... pasting several times yields different results. The first few times, only plain text (missing panels, and notes macro, as well as icons). 

A few more tries and then I got plain text plus icons (but all at their maximum size), and no formatting retained. 

This is insanely unacceptable especially considering that the new editor is now the default!

 

Then it gets even worse...

  • Attempting to just copy the text with the icons seems to randomly paste in the icons. But some are pasted as small, some blown up to what looks like 400%! Why?
  • Clicking on the correct size icons (100%), blows them up to 400%! Why? I no longer see an option to select the pixel size! Why? All that I see are minimal formatting options but no size adjustment. Even this forum editor allows typical four-corner drag resizing!!
    iconsize.png
    But the Learn the Basics explains that I can drag the handles! Sure, did anyone at Atlassian bother to beta test this? It doesn't work (to shrink) when the centered image is selected (like in my above capture). When the image is left-justified, I can shrink the image, BUT not to it's original 100% size! AND WHERE IS THE PRECISE PIXEL SIZING? You know, where I can enter a precise value?

 

I'm sure there are a 1000 other problems, but I'm exhausted. 

Atlassian, you need to tell me how to bring back the old editor as the default, otherwise I am going to have 100+ employees experiencing a lot of pain!

How could anyone think that this broken ill conceived editor was an improvement?

1 answer

3 votes

Hi Shawn,

If you have not yet done so I would recommend opening a ticket w/ Atlassian Support. The only reason I suggest this is that I suspect this thread will quickly become a discussion which is fine, but I expect you would want to actually get some direct help achieving your goal.

From my own experience, while I like aspects of the new editor, copying and pasting from an old page into a new one is indeed an exercise in futility depending on the source content/format. :-(

two more suggestions here:

  • Check out the Roadmap for the new editor
  • Be sure to click the Feedback link in your sidebar. I understand they are monitoring this feedback closely.

Thank you Jack. 

It probably seems obvious that I was really annoyed last night. LOL

I am mostly interested in knowing if the problems that I encountered last night are either:

  • User error (my fault)
  • Atlassian shortcomings in the product
  • Combination of both?

 

But yes, I will certainly issue a ticket with support, if the problems are not my own.

 

Thanks for replying. 

Like # people like this

Hi Jack (et al),

Before I post a bug report, can you or someone else please confirm that my initial observations are accurate and not simply user error?

 

Thank you

Never mind. After reading through an enormous number of complaints, I now understand that this is entirely Atlassian's fault!

I really hope Atlassian re-thinks the permanent switch-over to the new editor!

 

When were you planning to make that ill advised change-over?

I don't know because even the poorly wordy message is truncated! 

old editor warning.png 

Like Amanda Scott likes this
Dario B Atlassian Team Feb 20, 2020

@Shawn Connelly 

You can contact support to have the old editor enabled on your instance.

See the comment on CONFCLOUD-65695 for more details: 

Hi all,

 

Thanks for all the feedback on this ticket. Given the amount of requests we've started to explore what a potential quick win may look like to re-introduce this. That being said, we still can't guarantee a time frame for this - we will make sure to update this ticket as we know more on our end.

In the meantime, if you have the legacy template available - which most of you should have - you can keep using that to create new pages and still keep using this feature. If you don't have that template, you can reach out to support and we'll be happy to enable it for you.

Thanks,
Avinoam

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events