Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,398
Community Members
 
Community Events
168
Community Groups

How do you set the tree depth of the sidebar?

The sidebar of confluence on-demand limits the tree view to the top level pages. I would like to have the top two levels of pages displayed. (Like {page tree} with start depth = 2.)

2 answers

1 accepted

2 votes
Answer accepted
Alex Atlassian Team Apr 09, 2013

Hi Harley,

In OnDemand you should be able to navigate to the Look and Feel tab under Space Adminstration then select the Documentation Theme. Once you select the Documentation Theme a link will appear under it to "Configure Theme".

If you select "Configure Theme" you unselect "Page Tree" then add the Page Navigation Macro that you want to use.

Here is the documentation for the page tree macro.

https://confluence.atlassian.com/display/DOC/Page+Tree+Macro

I hope this helps!

Can we only have such a tree navigation if we choose the Documentation Theme? Would be nice in the defaul theme too!

It did. Once I knew where to find the sidebar, I was able to get started. I changed it to this:

*NameOfSpace*

----

*Search:*
{pagetreesearch}

-----

*Contents:*
{pagetree:startDepth=5}

It would help if the "macros" section of the document explained the text format of the macros. I tried a couple of times before I figured out that the seperator is ":" and not "|" as it appears in the normal fancy editor.

And *whoops*! That was supposed to be a comment on the above answer.

hey Harley,

so if I understand correctly, you changed the depth of the sidebar tree in a default theme ? can you give me more details about that? what file ? :)

thanks

The space which I modifed still has the custom sidebar.

I changed the sidebar a year ago, and am pretty sure our hosted confluence has been updated since then.

I went to check how I added this text, and I dont see how I can get back to edit the text. I think the UI changed and (a) either disabled the editing of it, or (b) moved the option to some config page which I didnt find.

wish I had more!

Thanks for your sidebar code, Harley. Marius, it's probably way too late, but I added it to the sidebar section in my space, using the instructions in the "Customising the Documentation Theme" section of this page: https://confluence.atlassian.com/display/DOC/Configuring+the+Documentation+Theme

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events