Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

vscode error

I have been using bitbucket for a couple of weeks or so with vscode without any issues. I'm uncertain what has happened but I'n getting a message popup in vscode. It says "Activating Bitbucket features failed".

 

So far I have logged out. removed the authentication and restarted vscode. I've even removed vscode from my computer at this point and reloading everything. So far I've not gotten passed this.

Any thoughts on what might have happened?

4 answers

1 accepted

2 votes
Answer accepted

Edit: many users have found that installing Git on the workstation running VSCode resolves this error.

--------------------------------------------------

Hey, welcome to the Community!

I haven't seen that error before personally, but would love to help you get VSCode working with Bitbucket again!

First can I confirm you're using the Atlassian-provided Jira and Bitbucket (Official) extension? There are a few others on the Marketplace that provide Bitbucket connectivity, but this is the one built and maintained by Atlassian.

By clicking on the blue bar down at the bottom of VS Code that says "Bitbucket: <your username>" you should be able to see the settings for Bitbucket:
image.png

Removing any existing connection and clicking "Login to Bitbucket Cloud" again would be another thing to try and see if you get a more specific error.

Let me know how things go!

Thanks,
Daniel

Daniel,

Thank you for the response, but do apologies for it taking a few days to get back with you.

It does appear that I'm using the "official" plugin. I'll include a screenshot. I've also have tried logging out and back in. I've even gone so far to completely remove all traces of vscode and then install again with the same issues. The attached screenshot from today post is actually from my new laptop which I just setup this week.

So I'm uncertain if there is something strange going on with my account or if there is something going on with the plug in. I might revisit the plugin page to review at required prerequisites in the meantime.screenshot.png

Hello, jus wanted to add that I am facing the same issue, this is a new installation of VSCode on a new machine, first run failed, I can log in into bitbucket though the extension but it fails to activate with the message shown above. Please let me know how can I provide debug information. I really like this extension to create PRs, so it's one of my favs, thanks!

@Daniel Eads  Please feel free to delete the Answer I added below, I did not mean to do that.

Daniel Eads Atlassian Team May 26, 2020

@mmickells and @Eduardo Gutiérrez Silva - our team is looking at the error to see if they can reproduce it and determine the cause.

Would both of you be able to double-check that the git extension is active in VSCode and not disabled? Thanks much!

Same issues here: first install of the Atlassian extension, and I get the "Activating Bitbucket features failed" notification.  My account names are showing up in the bottom/status bar, and clicking "Login to Bitbucket Cloud" instantly shows a success page in my browser and returns to VScode.

@Daniel Eads, pardon the question if it's ignorant, but which git extension are you referring to?  There are hundreds.

Daniel Eads Atlassian Team Jun 01, 2020

Hi @Kevin Camera - good callout. I'm referring to the built-in Git extension - you can find it by performing the search @builtin git in the Extensions panel. By clicking the cog, you can view its activation status.

Here's a screenshot showing that search, and with an enabled git extension:

image.png

Hello, mine started working from the past week on wards. I logged out of the extensions when I first reported, and after some time I logged in again and it worked. Thanks!

I have the same Problem, VS Code 1.45.1, installed the Official Jira and Bitbucket extension. Git UI 1.0.0 looks like in the Screenshot.
Tested on 2 different PCs (one with a fresh installation of VS Code).
The Activation via Browser by the extention seems to work, my Bitbucket Name then is in the Status Bar and the Message "Activating Bitbucket features failed" is displayed on the lower right.

Do I maybe have to create seperate SSH Keys to use the extention?
Thanks for the help!

Edit: a word

Daniel Eads Atlassian Team Jun 10, 2020

Hmm, getting some log info would be helpful in figuring out what's happening! Here's how to get the extension to write to the VS Code terminal:

  1. Go to the Settings for VS Code (⌘, on Mac or Ctrl , on Windows and Linux)
  2. Search for atlascode:output to find the preference we're going to set
  3. Change the dropdown to debug level

image.png

You can retrieve the logs from the Output tab in VS Code's terminal window. Switch to the Atlassian log:

image.png

Try getting it to connect again and we should get some error messages in the output. One step closer to solving the problem!

Like # people like this

1.png

I downloaded GIT on https://git-scm.com/download/win, then the Error went away...
Edit: Everything works now!

Like # people like this

I encountered the same error, installed GIT to resolve it. But now trying to open Atlassian Settings I am getting this error:

Command 'Atlassian: Open Settings' resulted in an error (ENOENT: no such file or directory, open 'build\asset-manifest.json')

Any help to resolve this issue with be appreciated. 

Thanks to @Daniel Eads  and @[deleted]. Installed the latest Git resolved the issue.

To @Aditya Adiga  I didn't encounter the issue you mentioned. Under extension folder (C:\Users\*currentuser*\.vscode\extensions\atlassian.atlascode-2.6.3\build) I can find the file. Have you tried to reinstall the extension? I copied the content of this file on my folder at below anyway, just in case if you wanna make the file manually.

 

{  "vendors~atlascodeCreateIssueScreen~atlascodeOnboardingV2~atlascodeSettingsV2~bitbucketIssuePageV2~cr~24f378a2.js""static/js/vendors~atlascodeCreateIssueScreen~atlascodeOnboardingV2~atlascodeSettingsV2~bitbucketIssuePageV2~cr~24f378a2.e97c0fe2.chunk.js",  "vendors~atlascodeCreateIssueScreen~atlascodeSettingsV2~bitbucketIssuePageV2~createBitbucketIssueScre~eec31edf.js""static/js/vendors~atlascodeCreateIssueScreen~atlascodeSettingsV2~bitbucketIssuePageV2~createBitbucketIssueScre~eec31edf.04dedec6.chunk.js",  "vendors~atlascodeCreateIssueScreen~bitbucketIssuePageV2~createPullRequestScreen~pipelineSummaryV2~pu~0fab74e6.js""static/js/vendors~atlascodeCreateIssueScreen~bitbucketIssuePageV2~createPullRequestScreen~pipelineSummaryV2~pu~0fab74e6.405852f9.chunk.js",  "vendors~atlascodeCreateIssueScreen~createBitbucketIssueScreen~createPullRequestScreen~pullRequestDet~0d663095.js""static/js/vendors~atlascodeCreateIssueScreen~createBitbucketIssueScreen~createPullRequestScreen~pullRequestDet~0d663095.b5e27797.chunk.js",  "vendors~atlascodeOnboardingV2~atlascodeSettingsV2~bitbucketIssuePageV2~pipelineSummaryV2~startWorkPa~e54bedca.js""static/js/vendors~atlascodeOnboardingV2~atlascodeSettingsV2~bitbucketIssuePageV2~pipelineSummaryV2~startWorkPa~e54bedca.72933ba4.chunk.js",  "vendors~atlascodeOnboardingV2~atlascodeSettingsV2~startWorkPageV2~welcomePageV2.js""static/js/vendors~atlascodeOnboardingV2~atlascodeSettingsV2~startWorkPageV2~welcomePageV2.25e2267e.chunk.js",  "atlascodeCreateIssueScreen.js""static/js/atlascodeCreateIssueScreen.37f81850.chunk.js",  "atlascodeOnboardingV2.js""static/js/atlascodeOnboardingV2.44c25e76.chunk.js",  "atlascodeSettingsV2.js""static/js/atlascodeSettingsV2.f45b9d27.chunk.js",  "bitbucketIssuePageV2.js""static/js/bitbucketIssuePageV2.f1efa5c6.chunk.js",  "createBitbucketIssueScreen.js""static/js/createBitbucketIssueScreen.946f3b63.chunk.js",  "createPullRequestScreen.js""static/js/createPullRequestScreen.ff159245.chunk.js",  "main.css""main.css",  "main.js""static/js/main.65d022dd.js",  "mui.js""static/js/mui.5cb310e8.js",  "pipelineSummaryV2.js""static/js/pipelineSummaryV2.bbffa7d0.chunk.js",  "pullRequestDetailsScreen.js""static/js/pullRequestDetailsScreen.182dee7b.chunk.js",  "startWorkOnIssueScreen.js""static/js/startWorkOnIssueScreen.db616d05.chunk.js",  "startWorkPageV2.js""static/js/startWorkPageV2.067c37a0.chunk.js",  "vendors~atlascodeOnboardingV2.js""static/js/vendors~atlascodeOnboardingV2.aa9079d9.chunk.js",  "vendors~createBitbucketIssueScreen.js""static/js/vendors~createBitbucketIssueScreen.2b70148a.chunk.js",  "vendors~pipelineSummaryV2.js""static/js/vendors~pipelineSummaryV2.13a6a32f.chunk.js",  "vendors~startWorkOnIssueScreen.js""static/js/vendors~startWorkOnIssueScreen.5fb20544.chunk.js",  "viewIssueScreen.js""static/js/viewIssueScreen.db25e2e8.chunk.js",  "welcomePageV2.js""static/js/welcomePageV2.d4bb5ea6.chunk.js"}

 

 

 

image.png

Update: Seeing the replies above fixed the issue on my machine as well.

I had the Git built-in extension in VScode, but I did *not* have Git installed locally and in my path.  I was doing all my development via remote clients (all of which *did* have Git installed), which is why I was only getting the error when I launched VScode, but not once I connected to a remote.

I have not seen the error again since installing Git locally.

I would make the humble suggestion that Atlassian consider updating the error message to make that condition more clear, which could prevent others from thinking it's actually an account/service issue.

Like # people like this

I was just going to comment the same thing! The extension threw a credential error and installing Git fixed it. A better error would be very helpful.

I had a new machine install on my Mac, found all I had to do was finish git installation/config.

So, in terminal typing "git --version" revealed I hadn't yet accepted Xcode's licence agreement, so "sudo xcodebuild -license" and accepting it finished the config, restarting VS and all was fine

0 votes
Akash.K I'm New Here Oct 30, 2020

Please check the debug log for git in VS code -

gitvs.PNG 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Calling any interview participants for Bitbucket Data Center

Hi everyone,  We are looking to learn more about development teams’ workflows and pain points, especially around DevOps, integrations, administration, scale, security, and the related challeng...

442 views 4 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you