Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,272
Community Members
 
Community Events
177
Community Groups

two-step verification and JetBrains PyCharm problem

Please help me solve the authorization problem:
I have 2-factor verification enabled
When cloning a repository, I used to enter my login - password.
And from now it asks me to enter the app password
I created an app password in the bitbucket settings
When I from the command line (Ubuntu / Debian) use "git clone <myrepo>"
and then enter login - app password. Everything is works fine
But here is problem: In JetBrains PyCharm CVS -> git -> manage remotes
I entering login-password: it asks for APP password
I enter the login -app password (exactly correct) - writes that the password is entered incorrectly.

1 answer

0 votes

Hi @volkovdmt,

Since the app password is working when you clone from command line, there doesn't seem to be an issue with app-password permissions (when it comes to cloning).

However, I am unsure what operations are performed in JetBrains PyCharm CVS -> git -> manage remotes when you enter the app password. It is possible that the operations performed need more permissions than the ones you have given to the app password or there is some different issue.

For testing purposes, I would suggest creating an app password with all permissions enabled and see if that works for you.

I would also suggest reaching out to JetBrains support to ask what are the minimum permissions required for the app password to work in that context and if there is another issue that may be causing this error.

Kind regards,
Theodora

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events