Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

ssh-host-key-changes did not work for me, cannot connect to bitbucket

revconcept August 17, 2023

Missed the emails about the changes, couldn't do a pull today so started digging. I'm not super versed in git commands or SSH, but I ran the commands in the provided instructions and they are not working.

I'm in terminal on Mac. This is the newest warning I get (which seems to be an improvement over what it was initially saying):

 

Warning: the ECDSA host key for 'bitbucket.org' differs from the key for the IP address '2406:da00:ff00::22cd:e0db'

Offending key for IP in /Users/Chris/.ssh/known_hosts2:341

Matching host key in /Users/Chris/.ssh/known_hosts:3

Are you sure you want to continue connecting (yes/no)?  

 I found a couple of posts with this issue and tried their solutions, but those didn't work for me either! I have hundereds of web development projects I need to be able to access...please help!

1 answer

1 accepted

0 votes
Answer accepted
Kurt Klinner
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
August 17, 2023

@revconcept 

 

The message you see is due to the host key changes, have you tried to remove the offending key from your known_hosts file (and potentially add the new one later on)?

 

Cheers

Kurt

revconcept August 18, 2023

So I believe that is what I attempted to do through the other post I found where someone had the same issue...but it did not resolve it. I'm *trying* to figure that out now...but this is not very familiar territory to me! I can git add/commit/pull etc but last time I set all this up was probably a decade ago!!

revconcept August 18, 2023

Ok, I got it working! I'm not sure if this is the correct/best method...but I noticed I had more than one known_host files so I moved two of them into a subfolder just to get them out of the way...after that I stopped getting the "offending key" message...but then it was telling me I didn't have access to my repos, so I manually added a public SSH key I created with the steps I found in BitBucket docs here - but it appears I will have to do this for each repo, which is unfortunate because I have MANY. But, it's working and I can move on with my life now ;)

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events