Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


ssh_exchange_identification: read: Software caused connection abort

Dear all,

I'm having troubles to perform the test after setting up the public key in my bitbucket account and executing following command: ssh -T

I've performed a debug as well and this is the result: 

$ ssh -v
OpenSSH_7.9p1, OpenSSL 1.1.1a 20 Nov 2018
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file /c/Users/jose.mudarra/.ssh/id_rsa type 0
debug1: identity file /c/Users/jose.mudarra/.ssh/id_rsa-cert type -1
debug1: identity file /c/Users/jose.mudarra/.ssh/id_dsa type -1
debug1: identity file /c/Users/jose.mudarra/.ssh/id_dsa-cert type -1
debug1: identity file /c/Users/jose.mudarra/.ssh/id_ecdsa type -1
debug1: identity file /c/Users/jose.mudarra/.ssh/id_ecdsa-cert type -1
debug1: identity file /c/Users/jose.mudarra/.ssh/id_ed25519 type -1
debug1: identity file /c/Users/jose.mudarra/.ssh/id_ed25519-cert type -1
debug1: identity file /c/Users/jose.mudarra/.ssh/id_xmss type -1
debug1: identity file /c/Users/jose.mudarra/.ssh/id_xmss-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_7.9
ssh_exchange_identification: read: Software caused connection abort


Any idea? 

Thanks in advance and regards,


1 answer

1 accepted

0 votes
Answer accepted
Stephen Sifers
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jun 11, 2019

Hello Jose and welcome to the Community!

Thank you for reporting this issue and providing your logs which include the error. We would suggest further testing of your SSH authentication to ensure it is functioning as expected. There are a few steps to this process and due to this, we will reference the documentation. Please review the following to test: Troubleshoot SSH issues | Test SSH authentication.

Additionally, ensure you’re using a connection with TLSv1.2. TLS 1 and 1.1 have been deprecating (Deprecating TLSv1 and TLSv1.1).

If you’re still having issues after going through the steps within the referenced material please let us know.

Stephen Sifers

Hi Stephen,

Thanks for your reply. Actually, I could perform set up my local folder with the remote repository with HTTPS url. I'm already uploading source code to Bitbucket and this GIT test is still not working. I've followed Troubleshoot SSH issues | Test SSH authentication. documentation, but no success. 

Anyway, I already can integrate with the remote repository. I don't understand what's going on with my test. 

Thanks for your help.

Best regards,


Hi, I'm having this problem now, when I use my internet at home, I can use fetch/pull/push easily. But when I'm at my mother's house, I can't operate and this error returns.

WhatsApp Image 2022-08-23 at 17.30.21.jpeg

Like astomiwanda likes this

I have the same error. Is there any solution?

instead of using SSH key try to use HTTPS link, because i had the same problem;
just do :
git remote - v 

then check which one is linked with HTTP link , in my case i found out that "source" is linked , and then use that" source" as <remote> and it will work
git push -u source ur_branch_name

I hope this will help youn because that works for me 

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events